It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Hello everyone,

I find it strange that I'm one of the few people on these forums who has this issue, but when I fire up my GOG copy of The Incredible Machine 3, it opens up in a fullscreen window, but most of the window is nothing but a gray area, except for the actual game taking up the center, but the cinematics and menu are displayed at an annoyingly small resolution, probably 600 x 480, if I'm guessing. Also, when I actually try to open up a level, the whole interface moves to the upper left, but remains at the same tiny size. Naturally, this makes it very hard to use the software in any way.

Now, I'm not asking for help getting TIM 3 running in genuine fullscreen that completely fits my 3840 x 2160 display, I'm mainly wondering why it's doing this weird thing, and how I can fix it so I don't have to massively squint my eyes every second that I'm playing this game in order to see (No pun intended) why people really enjoy this game.

If it helps, I already tried enabling the "Run this program in 600 x 480 (or whatever) resolution" under the compatibility settings, thinking that the image would at least be somewhat stretched to fit my monitor, but that didn't change a single thing...

Thanks in advance to anyone willing to help me!

EDIT: Here's what the main menu looks like
Post edited January 25, 2021 by Smron748
No posts in this topic were marked as the solution yet. If you can help, add your reply
In my opinion this issue cannot be solved, because it looks like the playfield cannot be resized and the parts cannot be made bigger. I see two workarounds for this.

1. Find a copy of The Incredible Machine 2. It's the same game as TIM3, but it runs on DOS, so DOSBox will solve the problem.
2. Ignore TIM3 and play Return of TIM: Contraptions instead. Most puzzles are taken straight from TIM3, there are some few ones, however some may be missing.

Also, you can manually change the resolution to a smaller one and then launch the game. That will work.
Post edited January 26, 2021 by JamesBond007
3 years later, does anyone have a solution yet? I've tried reinstalling the game multiple times, and also have enabled the "Run this program in 640x480." Compatibility mode is grayed out. I've tried running it in VMs of Windows 3.1, 95 and 98 and the game can't even launch. I ran the game in an XP VM, and the game launches with the opening 'Sierra' title and the little blue guy coming on screen, and then the game encounters a problem and crashes. I've even tried editing the [PlayField] section of "TIMWIN.INI" and still, nothing changes. This forum is the only thing I can find on the internet that mentions this issue of the playfield resolution.

So, is there a solution to this problem? Are there other people who just had the game work on install? I'm curious to know. I might poke around in the files a little more to see if I can change this resolution.