It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

So I've been playing this since yesterday, and every time I get to 4 years and go to gain a master level or whatever, it will give me the upgrade (to "restaurantuer" sp?) and then automatically start studying for the next upgrade (patrician), yet never complete. I cannot change occupations while it's studying, and there's nothing I can do. It's extremely frustrating because I can't enjoy the full game if I keep getting stuck here.

All times I've tried I was playing as a landlord. I'm not sure if the other professions are broken, but I am assuming they are.

I've uninstalled/reinstalled and it still doesn't work.

Pleas help!! I really really want to play the full game. D:
Seriously, no one knows anything? ARRRRRGH!!!! DDDDD;
CandiedJester: Seriously, no one knows anything? ARRRRRGH!!!! DDDDD;
I don't quite understand your problem. Are you trying to elevate one of your staff members to master? I didn't realise there was a next upgrade level. What result are you expecting?
No. The character I am playing. You can go into your house and click on the portrait, and it says when you hover over it "Gain new master grade" or something. Then when you click it it asks you if you want to spend 4AP to commence studies for the title of "resaurantuer" (since I'm playing as a tavern owner) and I say yes, then a little while later it grants me the title, and the next time I clcick on the portrait is says "You are studying for the title of Patrician!" Which is what comes after restaurantuer. It does it without me saying yes, and I can't cancel it, and I can't gain new occupations while it's studying, and it never finishes.

So, basically, I can get to level 2 of tavern owner and then it gets stuck indefinitely.
Well, looks like I'm NEVER going to get to play the guild. The glitch persisted even when I bought a new copy from an entirely different site. Exact same problem.
Post edited May 16, 2012 by CandiedJester
CandiedJester: Well, looks like I'm NEVER going to get to play the guild. Thanks to no one for your help.
The glitch persisted even when I bought a new copy from an entirely different site. Exact same problem.

No one is ever going to help me figure it out, not even gog support.

I hope you all enjoy your WORKING games......
Sorry, I missed your last reply, otherwise I would have responded. I'm afraid if the GOG version has this bug, it sounds like all versions will have it. I've not tried playing as a tavern owner myself, I went down the blacksmith route.

I don't know why you've encountered this bug, or if it's more general to all players. I have encountered a few bugs in the game myself (if you play as a trader, it's possible to discover that you can't actually trade with any other cities - They all say London). However owning a tavern is really a very small part of the game. I hope you'll try the rest of it, try one of the other routes. I can confirm that being a blacksmith or a stonemason works well.

I assume from your comment that you have already logged a support request? It's unlikely they can help you I'm afraid, GOG don't have the ability to actually bug fix the games, only to find workarounds or ask the developers to patch it (which is unlikely to happen). However those wizards in support can accomplish a lot, so give them time.

When you started afresh, did you copy in your savegame, or start a totally new game and work your way up again? With the trader bug, it's specific to a savegame, so if you've got it broke, it will require a restart to play it. If you've started new each time, it's more likely a general bug that's gone strangely unnoticed.
I've started many new games with the same problem, and uninstalled/reinstalled, etc.

Today I tried going down the blacksmith route with the new copy and it did the same thing. So I'm fairly sure it will just happen with every profession.

I would LOVE to explore the whole game, i just want to do it knowing I can actually advance.

Tomorrow or sometime soon I'm going to download it on my boyfriends computer (he has xp, I have vista), and I'll see if that works.

I know it's not jsut my own problem, because two other people mentioned having it, yet no one posted any solution.

P.S. thank you for replying!
Post edited May 14, 2012 by CandiedJester
I last played The Guild about a year ago, and none of the professions had given me that trouble. I will re-install it later today and try it, but humor me and answer me this checklist.

1) Is the game installed in a UAC-controlled folder? No matter how irrelevant this may seem, problems do arise where you least expect them.
2) Is it the same on all cities/difficulty levels?
3) What happens if you get an heir and switch to him, will he/she still be unable to train?

I do find this bug really weird, and it seems that those who encounter it are a minority, but let's see if we can figure it out.
Ok, found the time to install and check The Guild, and after spending about 30 mins trying to remember how to play as a landlord, I got to the part where you train for the next "level".
So, in the autumn of 1402, I got the chance to spend some time studying to improve my current profession, thus going from landlord to restauranter. I spent the APs, waited a bit, then I got the proclamation of "Congratulations. You have finished studying ... yada yada yada... you are now a restauranter. yada yada yada". Going back to the house and clicking on the portarit, it now says the usual of still needing time, and elligible for studying in season of year (I think summer of 1405, not really sure though).
So, I have the game installed in a non-UAC folder, and I'm running the TnL version with compatibility set to Windows XP SP3. If it still proves a no-go for you, upload your save somewhere and I'll take a look at it as soon as I find some time.
Well, I played through as an inn keeper, and got to the highest level, so I think it's just something about your setup. There are some annoying bugs in the game though. On this playthrough I couldn't create any new rooms in my inn. Seems everyone has their own "The Guild" bugs.
Okay, downloaded on my boyfriends computer and it still gave me the same exact problem.
So it's not just my computer. I must be doing something wrong.

I don't think I was running it in any compatibility mode, so I'll try doing that.
I use the non-T&L version, I tried the T&L one on my computer and it had a bunch of problems, so I went back to the other version.

Yes I've played it through in many cities and on different difficulties and they all do it.

I'm not sure whether it was downloaded into a UAC-controlled folder. It probably was on mine, but on this computer I'm not sure.

I'm not sure what happens if I switch to an heir, I never played that far in.

I tried uploading a save to this post and I don't think it worked.
CandiedJester: I tried uploading a save to this post and I don't think it worked.
Thank you for the update, so let's continue the troubleshooting, and hope we do find a solution.
UAC controlled folder is mostly the "Program Files" one in Windows Vista/7, Windows XP does not have UAC. If when you run a setup, it pops up a dialog asking permission to run it, then UAC is turned on, and it is a very good suggestion to install most (if not all) games, especially the ones, to another location (C:\Games for example).
To upload a save, you can either rename it to .jpg or .png and attach it, or you can use a filehoster like , [url=]Mediafire etc and post the link for the file here.
I'll try to upload later today a couple of my saves, one saved before starting training, one during training, and one when training finishes, to see if you can load them and work with them.
Be aware though that there is a significant time difference between our locations, so I doubt this will be a swift process, unless one of us turns nocturnal. Don't worry though, we'll get this game working for you.
It was downloaded into program files, but it never asks me for permission to run the game.
If xp doesn't have that and it still persisted it must not be the problem. And all my gog games download to the same place, and they all work perfectly.

I did try running it in compatibility mode for xp sp3. Still didn't work.

Thank you so much for helping me!

I'll give the link to two saves quickly, just have to switch computers. save #1, right before trying to gain a new master grade. Save #2, just after it granted me restaurantuer, and it starts studying for patrician.

p.s. I am pretty nocturnal. Haha.
Post edited May 17, 2012 by CandiedJester
Got the 2 saves, will test them later today (I hope). Will post any updates, along with my saves if needed.
I played as a Thief using the non-TnL executable, and installed the game outside of Program Files and I never encountered any problems with advancement.