It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

physx is bugged for the game. After trying the fix listed in this (gog) forum for the game I would get massive slowdowns any time a special effect (blue or green spheres from background obelisks) was on-screen or I approached the area that had one.

I disabled physx outright (I did it through the DefaultEngine.ini though it might work with just XEngine.ini) and noticed that it also fixed the auto-save stutter in the process where it'd freeze for a second any time an auto save occurrred.

Search for:


And change it to:

Post edited August 22, 2018 by WillyDio