It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Hi all,

We have uploaded a patch for the PC version of Tesla Effect that will update your game to version 1.3.

Changes in this new version resolve the following:

· Day 10 Crash

· Audio Stutter on Chandler

· Inability to enter Security Room in Tesla from saved game.

· A few additional Map bugs (tracked down by Mutant League Member: Bjyman)

· A few other issues.

Thanks and have a nice day :)

edit: the Mac version of the 1.3 patch added today (16.06.2014), please check your accounts for the new Mac patch!
Post edited June 16, 2014 by JudasIscariot
avatar
Jack.Ketch: I had the original game installed 2.0.0.7 without the intermediate patch installed and I can not install this latest one as it says my version of game is not supported.
For those of you with version 2.0.0.7 of our installer, please re-download the patch as we have uploaded a fixed version of it that should work with the older installer. Thanks :)
avatar
Siofra: Hi
I bought my father Tesla effect for Father's Day, Created an account for him and started the download using gog.downloader. It took the whole day of the 15th ( his laptop was already running slow, but with loads of free memory)and now his outlook contacts are gone. He is ready to kill me. Is it possible the game did this to his Outlook account?
Just want to add that the install kept crashing at 95%, and him trying to remove it from his computer proved a tricky business. I told him to leave it until I contacted you guys but you know how it is....
Ummm no? Our games shouldn't interfere with any email programs. I am not sure what's goin on here as we have never heard of this...
avatar
BinaryPoet: The patch usually patches the original version of the game, not the already patched one. Just reinstall the original game and then the patch straight after it. If you have kept the original installation files, you do not have to redownload anything at all.
avatar
sbenrap: In this case the original version was 2.0.0.7 before they re-compressed it and named it 2.0.0.9.

Those who got 2.0.0.7 really don't want to re-download 2.0.0.9
Please re-download the patch :)
avatar
v0gtlander: I get the message

This patch does not support your version of the game
please download a new installer

My version is 2.0.0.7 german
avatar
N.Rico: Get the same.

It´s sad, because I don´t want to download the 14 Gigs again (with only 3.000 kBit)

My version is also 2.0.0.7 german
Please re-download the patch :)
avatar
v0gtlander: I get the message

This patch does not support your version of the game
please download a new installer

My version is 2.0.0.7 german
Please try re-downloading the patch :)
Post edited June 16, 2014 by JudasIscariot
avatar
JudasIscariot: <snip>
Please try re-downloading the patch :)
avatar
sbenrap: Please leave a note to whoever will do future updates to take 2.0.0.7 into account in the future as well (will save this mess ;) )
It's been *sunglasses* noted :)