It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Already contacted support about this, but it's been nearly a full day and no answer, so now I'm hoping the community has answers for me.

Saw the base game and ashes of Uhrok at 75% off, decided that put it in my budget to get. Put both in the cart, suddenly sale prices go away. er, ok, let's get them on at a time...

Oh wait, now that I own Tales of Maj'Eyal the DLC is stuck at full price as long as I am logged in. If I log out, I can see it at the correctly discounted price. This applies on all three browsers I have tried, Microsoft Edge, Google Chrome, and the galaxy client itself. I really want that dlc at the sale price, so hoping someone knows some trick or whatever I'm not thinking of to actually get it, in case support doesn't get back to me before the sale ends or whatever.

... I'd attach screenshots, but the post thing freaked out when I tried. Vexing.

Oh, and Embers of Rage does the same, not that I plan to get it right now...
No posts in this topic were marked as the solution yet. If you can help, add your reply
Talked it over with a friend, and he had the idea of gifting it to me as a bypass, which got it at the correct sale price.

Still weird.
I have the same issue. It is odd
Very strange…

If you haven't played the game before, I would actually suggest that you play Embers of Rage first, because it's campaign is shorter (but not too short) and easier to manage.
aaaand sometime since I last looked, it seems to have magically corrected.

Same. Or discount was for only few hours.