It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

(Unable to find a support section or forum on the WHG or Tahira websites, so posting bugs here.)

During combat in Barr-Aaid, saved & quit to do other things. Upon resuming, the game loads the save up to showing the text '"The Light Shifts" / Barr-Aaid', overwrites the profile, and then fades to a black screen.

A concerning issue making this even worse: The game also deleted other profiles upon loading the corrupted one.

Originally I made copies of my profile occasionally precisely in case of bugs, and that went fine until I had five profiles. At that point the active profile became apparently corrupted, and the game began deleting the other profiles.

Unfortunate that I did not copy the backup saves to a completely different location. As it stands I appear to have lost my progress entirely rather than just to the last backup. Unless a future patch magically makes my save loadable again...

Browsing the game directory I found an "output_log.txt" file which contains a few errors like "The referenced script on this Behaviour is missing!", "Tried to check if a tile was in bounds before grid has been setup.", and "NullReferenceException: Object reference not set to an instance of an object".

Edit 1: More detailed description of actions and observations:

Occasionally copied save and renamed to a new profile, e.g.: "Profile1.sav" -copy-> "Profile1 - Copy.sav" -rename-> "Profile2.sav". This appeared to work fine. The game seems to continue from the copy in each case, but I am pretty sure I always used the 'Resume' option in the menu without manually selecting which profile to resume.

After creating Profile5.sav, at some point problems occurred. Unfortunately I cannot remember whether this was upon first resume after creating Profile5, or whether I had successfully resumed that save before it went wrong. I believe I probably created Profile5 before heading up the stairs to speak to Baruti and start the battle, in which case that save resumed successfully at that before-combat point, and only failed when I tried to resume after quitting during combat. It is also possible that the new before-combat save was Profile4 however, and I created Profile5 from the later in-combat state of Profile4. In the latter case Profile4.sav and Profile5.sav would have been identical files at the moment it went wrong.

When I attempted to Resume the in-combat save: Game loaded > clicked Resume > loading icon > the white 'scene name' text > black screen. After a while I Alt+F4'd. I forget whether at this point I first checked the savegame folder or just tried restarting & resuming again; probably the latter. When I did look at the savegames, I noticed that Profile1.sav and Profile2.sav had disappeared, and Profile3.sav to Profile5.sav had all updated their file modification time to the last Resume attempt. When I tried again, Profile3.sav and Profile4.sav disappeared too.

Attempting to recreate the issue by copying the corrupt save to all five slots: Immediately upon starting the game, before the main menu even loads, all five .sav files have their modification time updated, and Profile1.sav was deleted. Unfortunately on the next attempt to start the game, it updated the modification time, deleted saves 2-4, and then crashed with an error dialogue. (Not had that before.) Second attempt crashed again, third attempt oddly did load to menu.

On reflection, I cannot determine whether the issues of profiles deleting is related to the 5th profile slot irrespective of savegame corruption, or related to duplicate saves in multiple slots, or related to the corrupt save in whichever slot, or some weird combination of these. Duplicate saves seemed not to be a problem until I used the 5th slot.

System specs: Running on an old i7 860, 8 GB RAM, GTX 760 2 GB, Win10. Oh and spindle drive rather than SSD.

Edit 2: The fix in Patch 1.0.03 made my savegame loadable again. Have not investigated the profile deletion issue further.
Post edited September 08, 2016 by JeroenB