It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Ever since I discovered that SS Enhanced was updated to a new port that supported modding, I downloaded and installed it right away. I was hoping to play Rewired and Ruby Station, but, for some reason, the mods don't show up on the mission list. And before you say it, yes, I did put the folders I was supposed to move into the res/missions folder. The only mod SS Enhanced seems to read is the DOS faces one that is already packaged with it. Is there any configuration bugs that might prevent the port from playing mods?
No posts in this topic were marked as the solution yet. If you can help, add your reply
Try clicking on "missions".
I did. As I said, they won't show in "missions."
was just making sure, sometimes, people forget they actually have to click the button (this will hide the list of mods and show the list of available missions).

anyway, all extra missions need to go to the %APPDATA%\Nightdive Studios\System Shock EE\missions\ folder (any new mission needs to reside in its own folder there). also make sure you have the latest SSEESP packages for all the missions you are trying to load - Rewired for the old EE wrapper version will not work, for example.
Post edited February 18, 2019 by voodoo47
Thank you, voodoo47. The folder of the GOG version is different from other versions. For instance, you suggested %APPDATA%\Nightdive Studios\System Shock EE\missions\ folder. In my case, it's GOG Games\System Shock EE\Res\Missions folder. The appdata part is probably for other versions of the game. You maybe onto something about me needing the latest SSEESP packages for all my missions to work. Where do I find them, and how do I install them?
pretty sure GOG also uses APPDATA, because that's the version I (primarily) use. the latest version of Rewired can be obtained from its ModDB homepage.
Post edited February 18, 2019 by voodoo47
Maybe that APPDATA part is only applicable if you installed it with GOG Galaxy. I installed the backup copy without Galaxy. Part of the reason why is that I already have an earlier installed version of SS Enhanced (the first version, not the new version), and I didn't want to mess up the savegames I've already accumulated. I've installed it a different folder. But I don't think the earlier version of SS Enhanced with messing with the new version's ability to read mods. Both versions are very different, and they wouldn't interfere with each other. Besides, the latest version of SS Enhanced I have installed can read the DOS faces mod in its own folder. I still can't understand why it can read mods in its map folder. And I did put in the updated version of Rewired. It's getting more and more confusing why it doesn't work.
I indeed do use the Galaxy version, and my suggestion would be to just use that for playing Rewired - no idea whether the standalone build is up to date and whether the latest version of Rewired works with it.

also, this is pretty much all Microsoft's fault, as they are being stupid with the Program Files folder security permissions ever since Vista became a thing, but I don't want to start a rant here, just wanted to point out that both GOG and NightDive are not the culprit here.
Thank you, voodoo47. I shall see if I can give GOG Galaxy a try. The Microsoft permissions problems sounds likely. I'll give it a shot, and let you know when it works. Thanks.
This is very very strange. The problem still persists. I'm gonna fiddle around with it some more. See if I can find another way to get things to work.
Post edited February 18, 2019 by NedLand
the only thing that comes to mind is a redundant folder, meaning the mission files are placed in %APPDATA%\Nightdive Studios\System Shock EE\missions\Rewired\rewired\ (or similar) instead of just %APPDATA%\Nightdive Studios\System Shock EE\missions\Rewired\ (see the pic).
misloc.jpg (57 Kb)
No redundant folders. Interestingly, when I install SS Enhanced on my computer, it doesn't have the appdatas/nightdive/system shock ee structure as you did. I also tried it with the Steam version, and it still doesn't have that structure. Could it be that structures differ depending on computers? I have a Windows 7 Lenovo. Could there be a configuration error that causes the mod not to work on certain computers? It plays fine, but it doesn't read the mods. Maybe the mod folders need something else in them for SS EE to recognize them?
the appdata stuff gets created upon first run, if memory serves. also using win7 64bit (the screenshot is a dead giveaway), so that's not it. anyway, if mods are getting loaded from a location, fan missions should as well.

I think I'll try a clean install later this week.
Post edited February 18, 2019 by voodoo47
Hey, voodoo47. I finally got the mods working. Someone in another thread told me how to access Appdata. Even though it felt like a counterintuitive way to load the mods, I'm glad it finally worked. Thank you for trying to help me, and I'm sorry I didn't know how to do this sooner. But the loading system indeed works: it's just a matter of knowing where to find the damned Appdata. Again thanks.