It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
I inadvertently saved when I was three seconds away from being killed by an exploding antenna in Level 7. Despite my best efforts I can't get out of the situation legitimately. I can get to full health with the shield up, but that's not enough to save me, and I can't run far enough to get out range before perishing. So are there any cheat codes, save game editors or other tricks I could use to be invulnerable, escape through walls, or warp myself into a safer area? I've been playing the game for ~12 hours and I'd hate to see it end this way.

Yes yes, "save often and into different slots" and all that jazz, but that doesn't solve the problem in question.
No posts in this topic were marked as the solution yet. If you can help, add your reply
I managed to fix it myself! So in case somebody else makes a similar mistake and saves their game into an unwinnable situation, here's how to salvage it.

The Cutting Room Floor has a page for the game at https://tcrf.net/System_Shock. They mention that the game has a debug mode that can be activated by hex editing the .EXE file and changing offset 0x164E38 from 01 to 00. Among other things, this debug mode allows one to walk through walls and it even freezes time - exactly what I needed. However, this guide only applies to the game's original and CD-Rom releases, the Enhanced Edition's .EXE file simply doesn't have the offset. Maybe the debug mode could be activated by another offset, but I don't know how to find that out.

But then I started thinking that the save files between the CD-Rom release and Enhanced Edition might be compatible with each other. So I installed Classic Edition, hex edited CDSHOCK.EXE, copied my save file to [installation folder]\\SSHOCK\DATA and started the game. My game loaded exactly where I had left it, staring into a plastic explosive about to go off. But thanks to debug mode the time was frozen. I carefully walked out of the room, around a corner, and saved my game. Quit the game, copied the save file back to Enhanced Edition's folder, started that one, loaded the game...

BOOM

The explosion happens with me at a safe distance. My save file looks intact, everything looks to be working normally. Sweet.
Post edited October 10, 2015 by Ghegs
How did you manage to do this? I've tried hacking cdshock.exe in the classic install of this game and when I go to 0x164E38 in a hex editor, the value there is 00. I tried setting it to 01 just to see what would happen. Game functioned the same as normal.

UPDATE: Okay I found a way to find this value in the hex editor. But it's strange that it didn't appear when I went to the location as described in that article on tcrf.net. After searching the posts of the guy who found that debug mode on systemshock.org, I came across this little gem: sites.google.com/site/reimannshock/smallhacks.

It not only gives you the offset where the value is located, it also gives you a string of values that you can search on. This is how I ended up finding the correct value and changed it so I could enable the debug mode. I'm posting this in case anyone else wants to do this and has the same problems I did. :) Just so you're aware the string of values to search for is the following: 01 00 01 01 01 00 00 00

When you find that set of values, it's the first '01' you have to change to '00'.

PS: apologies for the lack of http on the links. For some reason the forum refuses to let me post with those in there.
Post edited December 11, 2015 by Hoky