It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I've just been going around trying to kill them by guessing. I thought something seemed odd about it but I had never played System Shock 2 until now. Does anyone else have this problem or know how to fix it?
This question / problem has been solved by Marvinimage
this is definitely odd. make sure you are not forcing anti aliasing via your gpu control panel. can you share a save?
If you use Rebirth, check you mod installation.

Do not force Adaptive Multi Sampling if you're an AMD/ATI user.
I have no mods installed. It's a clean GoG installation. I also just checked my AMD controls and I've turned off adaptive multisampling. I'll have to wait and report back if that works as I'm not encountering monkeys at the moment and I don't have a save that's near any.
Oddly, the very first monkey I encountered was visible. All the monkeys after that weren't. Haha I was quite baffled after being killed by a blue energy bolt coming from the floor.
I'm having the same issue. Also using a clean GoG installation. I've turned off everything I can think of in my AMD menu. I'm less worried about invisible monkeys than I am about things down the line that might be invisible as well.
a save with the invisible monkey would be great.
Where/how can I post it to you?
zip it, and drop it to sendspace or mediafire or similar. post the download link.
Marvin: If you use Rebirth, check you mod installation.

Do not force Adaptive Multi Sampling if you're an AMD/ATI user.
Changing Adaptive Multisampling to Supersampling in my ATI control center did the trick and now I can see those pesky monkeys again. Cheers Marvin.
Don't forget to mark solving posts, people can find solutions quicker that way.
That definitely did the trick for me. Thanks!
Does the GOG release include the NewDark troubleshooting document? Lots of common problems addressed in there.
yes, the doc folder is present (ss2tool install, remember?).
Great. Just great. Years ago this game conditioned me to spasm with fear whenever I heard soft monkey noises. Now they might be invisible as well. I'm not going to have a good time.
changing to supersampling did also fix my problem with the monekys :D