It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
System Shock Demo: Win7/64+16GB+GTX760+AMD-FX-8320E: intro, then "press space bar to play" screen is too large (double vertical res) and does nothing. can only kill it from task manager.
Here's a weird one for ya: When I first started the game, I didn't have this problem, but after a certain point my game kept walking me forward slowly even though I wasn't pressing any movement key. Turned the game off and back on and it has the same problem immediately.

Also, my performance is pretty chuggy. I'm running an I3 3.3 processor and have 1 gig of VRAM and 20 gigs of regular RAM. My rig isn't high-end, but I don't think it should be running at a single-digit framerate. Some graphics options would be nice.

I'm curious about the game at least, but I need to be able to properly play the thing to form an opinion. Hope to see some updates soon.
an update for the demo is already confirmed.
avatar
voodoo47: an update for the demo is already confirmed.
I tried to finish this (demo) twice now. Was crashing for me about 10-15 minutes. GPU constantly running on 100% also made it very hot. GTX960 w/2GB, 8GBRAm, 1080p, Win7/64. It's such a shame that they don't let me save the game so I have to restart every time it crashes.

Edit: Third crash (just after I finished the dark room with the repair bots, got down the ladder and walked along the floor with the zombie - killed that one saw tzhe next door and crash). Won't play it again before it got updated. My rig nearly never crashed and now three times in a row.
Post edited July 01, 2016 by MarkoH01
So, I "installed" this "patch" which amounted to dropping the new exe into the SSE folder and now I went from booting up SS and crashing to not even launching. I click on the exe and I'm greeted with a security warning. When I hit Run nothing. Nothing at all.
if you've tried everything suggested in the sticky, you should probably raise a support request via the GOG support system.
I am having the same issue as Telerien.
avatar
petePESTILENCE: I am having the same issue as Telerien.
I can report exactly the same experience.

With the default executable, the game crashes at launch (I see the Origin/EA screen when it happen).

I can "run as Administrator" but I should never need to do that.

With the RC patch, the game simply fails to run completely, even when I use the "run as Administrator" option.


UPDATE: I tried the game on another computer. The default EE install runs under my standard user account without incident (and I now have a new avenue to investigate on my main gaming computer), but the RC patch still fails to launch.

Is anyone able to run the currently linked RC patch? Maybe the executable is bad.
Post edited July 26, 2016 by DimensioT
With the help of GOG support (thank you), I learned that the patch linked in the first posting of this discussion is apparently bad. I was given a link to one that does work, however.

I also discovered that my crashing problem is related to MT-32 emulation, which I forgot that I had enabled for some old DOSBOX games. Switching back to another MIDI method fixed the crash-at-startup.

I have discovered that I cannot run the game at 1920x1200 resolution, as it crashes whenever viewing a log or email, but I can work with that (and such resolutions are known to be problematic anyway).
mind posting that link?

they probably should edit the first post and add it there.
Post edited July 27, 2016 by voodoo47
https://drive.google.com/a/gog.com/file/d/0B7quQTgSRc9KaS1DaHFTZ2VHTVU/view

I was given the above link by GOG support.

I am having an issue where certain areas in the game slow down horribly after the game has been running for a time (not many, but one are in Level 1 gets really bad). Resolution and other graphical settings don't seem to change this, but quitting and restarting seems to fix it.


EDIT: I can confirm that this addresses the endgame glitch. I just completed the game successfully a few minutes ago.
Post edited August 04, 2016 by DimensioT
--------ENDGAME SPOILERS---------

I was playing System Shock: Enhanced Edition when the elevator at level 6 heading into level 7 won't work after the part when SHODAN prevents me from using the escape pod. Are there any fixes for this bug? Thanks.

-------SPOILERS END HERE----------


EDIT: Ignore everything I said, It turns out that I had to click at the edge of the elevator door. :P
Post edited August 21, 2016 by ninjafan93
avatar
NightDiveStudios: LAST UPDATED: 18TH JUNE 2016

Hello!

This post is to help keep everyone up-to-date on the issues we currently know about and are trying to address.

We have a new patch ready for you good people to try out. Grab it here

It contain the following:

Fixed crashing for Raptr overlay users,
Fixed the rare inability to save on 1TB+ Hard Drives,
>> SPOILERS AHEAD >> - Fixed the timing of the final boss so that it takes slightly longer to cover the screen.

-

Crash on Startup
Hopefully Fixed. See above patch.

French and German Audio files are missing
The files have been added to GOG.com's FTP.

End Boss plays too fast
Fixed. See above patch.

Rare inability to save on 1TB+ hard drives
Fixed. See above patch.
The map won't let me place more than two or three messages on level 5. It says "cannot place message" in red which is bullshit because I've been able to place tons of messages in all levels before now, and even then I've still got lots on level's 1, 2 and R.

All my difficulty levels are at 2, just in case that has something to do with it.

I was also running the game through a Steam shortcut, but it has never caused problems like that before either.
Post edited August 21, 2016 by darkredshift
appears to be a bit newer than the GOG patch from a few posts above, though the GOG patch also includes ini and dat files. did you use both (GOG first, and then the one from NDS)? if not, I'd suggest doing that.
avatar
voodoo47: appears to be a bit newer than the GOG patch from a few posts above, though the GOG patch also includes ini and dat files. did you use both (GOG first, and then the one from NDS)? if not, I'd suggest doing that.
I haven't patched the game since I got it because GOG games don't automatically download updates like Steam does and it's not likely for me to know an update exists. If it's a patch available on the game's entry on my account page, then I download it from there and install it but sometimes it's a brand new version of the whole game like System Shock 2, where I needed to get the new main game installer in order for my mods to work.

I don't know what NDS is.
Post edited August 21, 2016 by darkredshift