It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
GOG has set up Syndicate Wars to run at max cycles, which is way, way faster than it needs. I want to edit the conf file to drop the number of cycles to a fixed number, but when I save the file and start the game, it is still running at max. Has GOG altered the executable somehow to always run at max regardless of the conf setting?
Post edited January 19, 2016 by ThreeSon
No posts in this topic were marked as the solution yet. If you can help, add your reply
avatar
ThreeSon: Has GOG altered the executable somehow to always run at max regardless of the conf setting?
How are you launching the game?
avatar
ThreeSon: Has GOG altered the executable somehow to always run at max regardless of the conf setting?
avatar
Gydion: How are you launching the game?
I've launched it using both the GOG-created shortcut in my start menu, and also directly through the Galaxy client. In both cases the speed is running at max no matter what I change it to in the dosboxSWARS.conf file.

If you own Syndicate Wars on GOG, do you also see this same behavior?
avatar
ThreeSon: I've launched it using both the GOG-created shortcut in my start menu...

If you own Syndicate Wars on GOG, do you also see this same behavior?
Unfortunately, I don't own this one. Check the start menu shortcut to see what the actual launch command is. Galaxy may be using different .conf files.
Post edited January 20, 2016 by Gydion
avatar
ThreeSon: I've launched it using both the GOG-created shortcut in my start menu...

If you own Syndicate Wars on GOG, do you also see this same behavior?
avatar
Gydion: Unfortunately, I don't own this one. Check the start menu shortcut to see what the actual launch command is. Galaxy may be using different .conf files.
Yeah I've checked out the shortcut. The conf files are correct - meaning that it uses "dosboxSWARS.conf" for the configuration and "dosboxSWARS_single.conf" for the DOSBox autoexec. So I've definitely got the right conf file.

I submitted a support request to GOG but I have a feeling it will take a while to get this sorted out.
avatar
ThreeSon: So I've definitely got the right conf file.
I forget which game it is now, but IIRC, Galaxy wasn't using the .conf files in the game directory. Instead it was using ones, with the same name, under some Galaxy directory.
avatar
ThreeSon: So I've definitely got the right conf file.
avatar
Gydion: I forget which game it is now, but IIRC, Galaxy wasn't using the .conf files in the game directory. Instead it was using ones, with the same name, under some Galaxy directory.
Well I did a search through my computer but I couldn't find any other folder that might contain separate conf files. However I'm 99% certain Galaxy uses the conf files in the game's folder, because I can change settings for other DOSBox games like Syndicate Plus in those conf files, and when I run the games through Galaxy the changes are properly implemented.

I got a response from GOG support that suggests that Syndicate Wars is a special case DOSBox game where they made a custom DOSBox executable that locks the conf settings. They suggested trying the Windows port but the setup process for that is rather confusing, and there are also reports that there are speed problems with that version too.

So I think I'm out of luck with this game.
I came, I saw, I tinkered with files and found a fix! Sort of... -Julius Caesar

They didn't make an .exe they just created a batch file. In the Syndicate Wars folder should be an \SWARS folder with PLAY.BAT containing the following code...

cycles = max limit 20000
@SMACKPLY.EXE c:\SWARS\QDATA\INTRO.SMK
cycles = max limit 120000
@main /w /g


Gog have placed two cycle adjustments before the intro and the main game, the first one is unnecessary and the second one is interfering with the DOSBox config file so let's delete them both leaving just the lines that start with '@'. You can edit .bat files with notepad or wordpad. Remember to save the changes and not to change the .bat file extension.

BTW! Do not edit the path to the intro video in the .bat file if you think it looks wrong. That is the path DOSBox pretends the game is at for the emulator, it is not wrong.

Now we can go back up to the folder above and tamper with another file. dosboxSWARS.conf

Syndicate Wars still has a major problem, it's main executable can't regulate framerate so whichever cycle count you choose you are going to have either fast and horrible menus or slow and horrible gameplay. Unless of course you don't mind using a key combo like one of those 'turbo buttons' old computers had to let them switch cycles on the fly...

Open dosboxSWARS.conf and find the following three lines...

cycles=100000
cycleup=10000
cycledown=10000


Change them to read...

cycles=25000
cycleup=100000
cycledown=100000


All three lines are different, not just the first. If you miss a zero then that makes you someone who misses zeroes.

Save these changes also. Now what this means is that the game will run at 25,000 cycles giving the menus a decent compromise between not looking to speedy, but not having noticeable mouse trails. This low cycle count is crap for the actual gameplay though, but by pressing CTRL+F11 you will cycle-up by 100,000 to 125,000 cycles which I think makes the game look great and play great (you can tinker with your own numbers.)

When you complete a mission simply press CTRL+F12 to drop back down to 25,000. See? Just like that turbo button that really old shitty computers had when Amigas were faster.

I hope zis helps und is understandable. I hate typing instructions. I might try to tidy this up or make a new sticky thread or some mischief like that.

krashd
Post edited February 05, 2016 by krashd
Tried it - Worked!

Dear krashd, i own syndicate wars on CD, some version i found in the internets and now i bought it on gog because is simply love the game. However, i always had the problem with the max cycles in the menu. Those breathing endo-skeletons looked like they where hyperventilating which killed the mood for me.

I want to say Thank You very much for providing a solution for this problem, though a cycles Value of 40000 works better for me! You are the real MVP.
Post edited June 18, 2017 by H0sti