It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Tried already 3 times. Once the last battle ends, and the elevator speeds up to reach the top floor, once there, there is some flickering in textures and I can't leave the levator platform. It lloks like Reynardo is hiting a wall.
No posts in this topic were marked as the solution yet. If you can help, add your reply
I have the same issue. Tried several times to no good end. The platform moves rapidly to the stop point and then there is a small gap between the platform and the intended pathway which cannot be crossed.

This needs a fix.

The game is stuck in the loop (much like the game itself!)

Please help.


Not sure if this will help you, but I lowered the graphics level to medium and then tried. It worked!

It brought me to a doorway and not a dusty pathway this time.

Give it a go and see if it helps you out as well.
Post edited September 24, 2017 by Faithful
I have the issue as well. I am disappointed since april 2016, devs did'nt have fixed it...

I'm going to test Faithul solution and I'll update my post.
I have the same problem. The Faithul solution don't work for me... But thanks anyway.

PS : It works for me if the game is windowed in 1280/720p and on low graphics :)
Post edited November 12, 2017 by josepe139