It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

i don't see anyone else with this issue. i even tried remapping in options. i have no idea what info i can offer. i have tried to track down any info. please help.
This question / problem has been solved by StellarTacticsimage
Is that rotating with the keyboard or mouse? I'll check here to see if the default keyboard binds (left and right arrow) are working correctly. I usually use the mouse.

Also, under "Gameplay" in the options menu there are camera rotation speed sliders. I'm wondering if adjusting those make any difference for you.
Post edited May 21, 2021 by StellarTactics
Thank you so much for your swift response! Your suggestion regarding the speed sliders in the gameplay tab did the trick! I am sorry i missed it before starting a thread. The sliders were set to zero, but unaware, i only tried the keyboard commands to eliminate my mouse as the problem. Both methods work well since that the adjustment was made.

Your game is very good in my first few hours experience. I look forward to what you will do in the future!
Glad to hear that helped and you are enjoying the game.