It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
First of all - why post such list here, instead of reporting it directly to devs? Oh, boy, trust me - I tried, hard. Sadly, it is as good as trying to wait on (in-game) corps contact lines without having positive rep with them:

1. The "contact" form on:
http://starcrawlers.com/

...is defunct for at least a year now (checked - it doesn't work for anyone, not just me). Ironically enough, trying to send anything result in a prompt asking you to try in a moment (could as well be "please hold on the line, your call is important to us"...)

2. "Official" forum:
http://www.starcrawlers.com/forum/

...is a necropolis, with last active posts being made many years ago, from "Early Acess" time - it seems that staff isn't using it anymore since Starcrawlers got released.

3. The Starcrawler's steam forum:
https://steamcommunity.com/app/318970/discussions/

...which - *sadly* - seems to be handled by devs as main way of communicating with playerbase - is locked for writing only for purchasers on Steam. Why they are using it, instead of their own official-and-abandoned forum, is beyond me. Probably having something to do with conformism of using most active platform only, and - not purposely, but not less irritatingly - showing a middle finger to customers from other fronts.

4. The contact mail:
contact@juggernaut-games.com

...that was provided by devs as alternate mean of contact at some point, to player notifying of broken contact form on main page, seems to be linked to /dev/null. Been sending bug reports there for more than a month already, never got anything that would confirm at least someone is reading it.
---

So, I'm going to stick the bug report "poster" here - for as much good as it is gonna do (probably, little).

Don't get me wrong - Starcrawlers is an awesome game that i completely adore, even at its current more-than-average bug infested state. The devs were awesome for a whole (long) production and early access time, and I would find iot hard to believe that they abandoned a game that is so obviously a labor of love, clear talent, and erudition in best games of last 30 years. I guess it is "just" a case of horrendously mishandled communication and feedback maintaining (even being aware of them being two, or - at most - four people with a huge game - sympathizing, but honestly, I saw even smaller teams managing to *not* screw comms so much with equally big games).

Having that in mind, it is definitely *not* my best experience with (trying to) providing bug reports in Indie's world. Hoping it is gonna to improve. Maybe.
---

Anyway, for the "Grand Bug List" (tm), as taken directly from my mail send to /dev/null... erm, contact@juggernaut-games.com:

"Hello Juggernauts,
I have quite a bunch of issues to report - I am pretty certain that
you're aware of some of them, but bug section on your forum appears
ancient (from old times of early access), and I'm not user of a Steam,
where you, presumably, gather reports nowadays. So, to the point:

1. If one repairs deck and/or heal party members/cure status effect
from post-mission screen, one is paying less, than if done manually,
afterwards, using correct vendor's menu (at least it is the case on
highest "hardcore" difficulty level). It *seems* that curing status
effects from post battle screen also prevent contracting "Serious
injuries", but it might also been my luck due to #2 that follows:

2. "Hardcore"'s level permanent-post battle injuries are not permanent
(can be "fixed" in medbay for hefty sum of credits", and they seem to
happen very rarely - during tons of my playthrough, I actually saw
injuries twice on downed crawlers. More often than not, they revive
without any injuries (sometimes, even without regular missing organs).

3. Enemies with "confused" debuff *always* attack own teammates, and
don't attack anyone, if they're only one member of their team. They
never attack crawlers - it is like they are under "charm" debuff,
despite being not. This makes abilities that confuse enemies much more
potent than it should (being equivalent of much more rare and harder
to get "charm" effect).

It is worth mentioning, that "confused" crawlers work as they should
(attack random target).

4. "Special delivery" ability of Engineer doesn't work as it should
(tested lvl 3 of ability):
a) only junker seems to go away in a boom - blasto and sapper doesn't,
neither non blow-on-
command (sapper) or when timing out (both). Not tested with thumper,
might be affected or not.

*supplement - further testing proved that blasto and sapper seems to *sometimes* blow up on time-out (no idea what causes it to not being working sometimes), but definitely and 100% reproducibly, sapper doesn't do "special delivery" when ordered to blow up.

5. The "Good housekeeping" story mission have quite scary bug - if you
unlock the "shortcut hatch", use it, then scout whole area anyway
(going through all the areas you would have been through if not using
shortcut), *then* you enter the shortcut hatch again, door leading out
of shortcut area is permanently closed.

At the same time, the hatch dialog - on the inside side - ask if we
want to go back, but only possible reply is leaving the hatch alone -
essentially making one stuck in the garbage-filled tunnel, eternally.

Fortunately, eternity isn't that long if one save+quit and reload game
- the stuck exit door becomes unstuck, again.

6. If one's fail to hack security panel in any room, and the result is
"disabled the security in the room, but triggered an alarm", neither
happens - the security things are *not* disabled, and alarm level does
*not* raise. It is just the panel itself becoming inaccessible for
further attempts.

6b. Same for soldier shooting down the security/blaster/gamma/whatever cams - in fact, he can shoot whatever he want with even minimal point sin the tree, cause failures are same as success in practice, despite flavor text about raising an alarm (camera goes 'pop', but no alarm get triggered nor raised).

7. Custom name of Wire hacking deck is "lost" between saves - it is
still displayed after loading game, but in-fight it defaults to
"Core". One needs to get into deck settings at least once after every load to bring it back.
(continuation, cause stupid GOG's post form have hidden character limit and just silently fails to post when exceeded, had to split it up...)
---

8. If "imposter" (and similar) enemy type is encountered during Wire
hacking, fight sequence breaks - shortly after cloning, enemies start
to attack in real-time, ignoring turns, time units, and everything
else (in fact, also bringing frames per second to a halt due to
attacking few times per second). It is possible to lose few K hp deck
in few seconds, this way - only rescue is to successfully run on first
action and avoid that node.
^
This one seriously breaks Wire hacking at higher levels, sadly.

*Supplement:
In fact, they're not attacking in real time - further testing proved that they are just doing arbitrary number of rounds during one move (like, attacking 6 times instead of one, at same time). Effects that last for certain amount of time prove this (for example, debuff that should last 4 turns can go away after their 4-in-1 attack).

9. Last but not least - while I know you're aware of it - just a heds
up, that Linux users - like me - wait eagerly for fix allowing us to
utilize permanent free-look without the "unknown offset cursor" issue.
My index finger could really take a rest, instead of holding the right
mouse button all the time ;)
---

In any case, HUGE kudos for Starcrawlers - I was following the
development since very early announcements (in fact, since Ben Prunty
announced he is doing score for some awesome project), and what you
delivered is awesome (the bugs notwithstanding). Starcrawlers made it
to one of my favorite games of all times, and I *am* a very old gamer
;)

Cheers,
/CatLady"
---
Post edited November 26, 2018 by Estel_
Mail 2:

"Supplement:

10. Engineer's "Twofer" skill doesn't work correctly - in fact, every
construct "clone" last exactly one turn less, than it should (so, at
lvl 1 it should last 2 turns, but disappear after one, etc.)

Super-Suplement:
Contact form on your webpage doesn't work. Every attempt to send a
support message ends up with:
"Failed! The error occured, message is not sent. Please try again later. "

Of course, trying again later works as good as holding on the corp's
lines when prompted - without enough rep. Speaking of which - it would
be awesome to have some (even automatic) confirmation that bug reports
via this mail were received/acknowledged, cause as it stands I'm not
sure if it isn't just going to /dev/null ;)

Cheers,
/CatLady"
---

Mail 3:
Super-Suplement:

1. You're probably well aware about it, but not only "Imposter" is
problematic - "Mimic" is even worse, cause he doesn't only kill your
deck on never-ending enemy attack loop, but also make you soft-lock in
the battle, forcing you to kill the game process and lose all progress
during a mission.

Specifically, when mimics stops mimicking a type of enemy, game tend
to just "stop" after mimiced enemy disappears, but before mimic
appears again - timeline indicates it is his turn, but nothing
happens. You can click on various thing on screen (read descriptions,
etc), but no way to a advance fight OR leave battle.

Might be related to (de)buffs being present on mimic before he started
mimicking something (for example, dedompile - it seems to "freeze"
when mimic starts mimicking, and return to where it was when he stops,
only that it can not advance due to battle getting HALT'ed). Or might
be not, not much of a way to provide a save for debugging (cause no
way to create one when getting the bug).

2. Saving during a mission where you did some Wire-hacking, (be it
manual save or just save and quit) means that - upon loading - the
Wire is in pristine state, aka you need to re-hack everything you did
before (losing deck's HP again, and potentially gaining another boons
from looted datastores). Found this bug as I tend to jack out and save
if encountering mimic/imposter in case they decide to break my game
with the damn bugs...

3. Not exactly a bug in game, but providing feedback - if not a steam
buyer - isn't exactly a stellar experience. Only steam buyers can
write on Steam forum, the non-steam forum:
http://www.starcrawlers.com/forum/

...is super-outdated and dead, the "contact" form on your webpage is
broken for ages, and sending bug reports to this very mail:
contact@juggernaut-games.com

...feels like sending thing to /dev/null without even any basic
"recipient acknowledged". Ironically enough, it is not much unlike
contacting customer lines on the corps in-game before having enough
rep with them (except Astrohound, they talk from start - be more like
Astrohound, please ;) )

Cheers,
/CatLady

PS.

I get it that you might be all busy with the next update, but if
releasing just a hotfix for game-breaking bugs during wire hacking -
the mimic/imposter thing - is an option, it would be greatly
appreciated. It is *infuriating* as it stands, if you are one of the
people that enjoy wire hacking (and its connection with meatspace
starcrawlers world), despite it being hopeless money pit."

Well, what can I add... Cheers, /CatLady ;)
[1.1.2] A deck battle ended without resolving, so I couldn't leave the battlefield, nor save the game: I had to quit and lost my run progression (I must chose another mission). So, we have to save often in mission, the best is each time before we connect the wire.
Waiting for the next patch to play; bored with all these added (new kind) bugs.
Post edited December 28, 2018 by ERISS
Let me add one to the list: If I flee from a hacking battle I am stuck on a black screen and I can't really do anything.

Workaround: Hit ESC, save and quit to main menu. Continue.
Another one: On one mission the mission item is supposed to be a datachip, but it is actually called "pocket fusion core" or something along those lines and is listed as a loot item that can't be sold for anything. I didn't notice when I picked it up and later got rid of it when my inventory filled up. This makes the mission goal red (0/1 items) and the item appears back in the box it was in at first. Picking it up again makes the mission goal green again (1/1 items), however after leaving the mission faled (the "do you want to leave" screen also claims you have the item). Going back to the save before the item was discarded and leaving without ever discarding it does work.

On the same level I saw the box with no exit option thing, however with random clicking and hitting keys and waiting a bit it went away fairly quickly.

This is in 1.1.3.3 I think, however it claims to be 1.1.3.2 on the main menu page. I installed the 1.1.3.3 windows offline files and even tried the 1.1.3.2 to 1.1.3.3 patch. I'm fairly sure I had installed 1.1.3.3 before I saw the box with no exit option but I'm not 100% sure (I reinstalled and tried the patch after I found the misssion failed thing and that the main menu still said 1.1.3.2).
First: when hacking, if one starts a mission with a damaged deck, and completes the mission without being hit (using a shield program in all combat), then the damage is repaired automatically, free.
Posted in a separate thread, but this seems to be as good a place for it as any.

I've run into three bugs with side missions on three normal missions in a row.

The first one was to be monitored by Chimera by wearing one of their pieces of gear as an accessory on my next mission. One of my characters wore it, but then I didn't put them on the mission. I had to report that I lost the device. They gave me another one. I wore them both on my next mission, and still did not get credit for it. My Cyberninja was still nauseous at the end of the mission, and that condition could not get cleared up by the Medbay. (I had to use one of the Cerulean Crystals from a mine to get rid of that condition...see below for my problem with that mission.)

Next, I was on a mission with Rhyzsom (spelling?) to get daata from the mainframes in the server rooms. The next mission that I took was to secure some device in one of their labs that had been overrun by native lifeforms. I got to the server room, but there was no way to access their mainframe. Was this because it was one of their facilities?

Finally, I'm on a mission in a set of mines, and I have the side mission from HEHS to sabotage three mining drills. I have been able to sabotage two of them with no problems. I have the third one right in front of me, but I cannot activate it. I can step on the square that the drill is on, but that doesn't seem to do anything either. it's in front of one of the chunky rock texture squares.

Has anyone else run into any of these issues?
In a combat I stun a robot, and I can do nothing more, the combat is stopped, unresolved. I had to quit the game.
I hoped this game would no longer brake our missions... Disappointed, we still have to fear bugs and save often.
If you can't patch combats, please make an autosave before them, at least for you, to make us able to send the problem...
Post edited May 05, 2020 by ERISS
I had a weird bug yesterday that during combat I wasn't able to click to choose my combat skills and other options, I think it happened right as I clicked one of my character's turn icon to check the debuffs they had and after closing it I then wasn't able to click anything anymore and had to restart the game.
Not sure if this will ever be handled now that Chimera's in the works, but there are a few bugs (or at least weird interactions) between force psyker abilities:

- Spirit Onslaught rank 3 doesn't seem to work with mind bullets. I'm not sure if it works in general since I haven't kept count of the crits, but my feeling is no (simply because I've only healed when other stuff happened).
- Mirror Prism isn't an "ally" for the purposes of barriers and such, but it is an ally for the purposes of Manifest Spirit rank 3, making triggering the 20% heal several times per combat trivial