It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Hey all. So i'd taken a break from this game for a while, but everything was working fine last time.
I'm playing on windows 10 on a mac using bootcamp.

But now when i play this, the throttle doesn't seem to work at all. It used to at least go in 1/3 increments, but now it's just not doing anything. I tried resetting the joystick settings in the game, but now it just automatically changes to "throttle at 2/3 power" as soon as i start a mission. I think a couple buttons on the joystick are set to throttle settings but even after i use one of those it goes back to 2/3. And the throttle itself still isn't doing anything. And when I'm in the joystick settings, moving the joystick doesn't do anything, but i don't think that was the case before either. I think the game automatically understood the throttle as soon as i got it.

I'm using a thrustmaster t flight hotas x fwiw.

I have tried uninstalling it in windows, re-downloading drivers, etc.

thanks for any help :)
No posts in this topic were marked as the solution yet. If you can help, add your reply
omg i literally spent about an hour working on this

turns out my joystick was on PS3 mode and not PC mode