It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
My game sound cut out at the start of level 2 on swtfu1. Sound worked just fine in first level, cutscenes, main menu, but once I had control of my character in the second level, raxus prime, no more sound, not even in menus. I figured it was just an odd glitch that would resolve itself when I restarted, but it was late so I shut it down and hadn't got back till now. The problem continues, I have sound until the level loads and I get control of my character, then no more sound from the game. I closed the game and started another program and the sound was working on that fine, then to see if it was a GoG Galaxy error, I loaded another GoG game and that worked fine. I don't want to reinstall if I don't have to as GoG downloads take forever. Does anyone know what might cause this error, or how to fix it?
No posts in this topic were marked as the solution yet. If you can help, add your reply