It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
The game just won't start at all. Please use simple language when helping me. I'm not a computer guy.
No posts in this topic were marked as the solution yet. If you can help, add your reply
avatar
Loweflem: The game just won't start at all. Please use simple language when helping me. I'm not a computer guy.
Hi, Loweflem.

There are a couple of things you can try:

1) In the folder where you installed Knights of the Old Republic (mine is located at C:\Games\Steam\SteamApps\common\swkotor - your install location will be whatever folder you selected in the GOG installer) you'll find a file called swkotor.ini. If you don't see the .ini portion of the file's name, look for an icon that resembles a page with a gear on it called swkotor.

2) Open the file in Notepad or your text editor of choice.

3) Look in the section headed with [Graphics Options]. In that section may be a line - Disable Vertex Buffer Objects=1

4) If you don't see that line (I believe it's in the file provided by GOG though), than copy it in to the file at the end of that section (before the line that says [Autopause Options]

5) If the movies aren't showing when you open the game, you may want to add the line Disable Movies=1 at the end of the section labeled [Game Options].

And the usual - make sure drivers are up to date, etc. Hope this helps. =)

Flynn
Thanks for the help, but....

The line "Disable Vertex Buffer Objects=1" is there in the file and my drivers are updated.
How many goats do I sacrifice to get my game to start?
avatar
Loweflem: Thanks for the help, but....

The line "Disable Vertex Buffer Objects=1" is there in the file and my drivers are updated.
How many goats do I sacrifice to get my game to start?
Try step 5 and see if the game launches. Beyond that, you can try setting the swkotor.exe (icon looks like a head) to Windows 7 or Windows XP SP2 compatibility mode and see if that helps. =)

Flynn
As Flynn suggested, try disabling movies, that is the only solution that worked for me. It sucks not being able to see the movies throughout the game, but that is the only way I got it to work on my Windows 8 laptop. Hope it works for you, I just finished it a couple days ago and had a blast!
avatar
JogsterXL: As Flynn suggested, try disabling movies, that is the only solution that worked for me. It sucks not being able to see the movies throughout the game, but that is the only way I got it to work on my Windows 8 laptop. Hope it works for you, I just finished it a couple days ago and had a blast!
Honestly, I took this one step further (granted I have the Steam versions). It is almost impossible to get this game to play with the movies enabled. 90% of the problems encountered are due to the movies. I simply deleted the movie folders from both games. You can't watch them regardless, and it has no negative effect on gameplay or stability whatsoever, and you can save yourself a couple of gigs as well.

The reason I eventually did this is because turning off the movies in the KOTOR2 config file does't actually seem to do anything. They still show up as normal. But if they aren't even installed, the game just skips them and moves on, which is what you are looking to do anyway. It seems extreme, but seriously, deleting the movie folder in each game solves a ton of problems.
I'm having the same problem but with win7. I have tried everything in the support section (got old directx, compatibility modes, drivers), reinstalled the game in win xp sp2 compatibility mode, disabled the movies, removed the movies and I still cannot get the game to launch what so ever. All I get is the flicker, windows color scheme turns to basic for a second, reverts to aero and nothing.

I have 0 problems running KOTOR 1.
The movies work fine for me. I'm on win 8.1 64-bit.
nope Im in the same boat as Mont3core only bought the game a couple of hours ago and have the same exact problem and have completed KOTOR 1 several times without changing anyting

I just found a solution that worked from the thread on KOTOR 1 I deleted the atioglxx.dll file and it run straight away no crash after character creation or anything, funny that I didnt have to do it with 1 but I have to with 2. Now to see if it works when I re-install to get the movies back :)
Post edited January 24, 2015 by Grimfang.120
I just got my mind blown by GOG support! I put in a ticket about this issue and Genoan responded within like 30 minutes. He noticed in my dxdiag that i had a 120hz monitor and suggested trying 60. Needless to say the game ran perfectly once I switched it.

In all of my searching I hadn't seen anything about refresh rates, but GOG support nailed that shit! I'm so excited, I love this website! :D
I tried all the above "fixes" but none worked. I contacted gog, and hopefully they will see something that I am missing. Like many, this is one of my favorite games of all time! The weird thing, KOTOR 2 started up without an issue...
avatar
GeneStarwind: I tried all the above "fixes" but none worked. I contacted gog, and hopefully they will see something that I am missing. Like many, this is one of my favorite games of all time! The weird thing, KOTOR 2 started up without an issue...
You didn't install them to the same folder did you?
avatar
Grimfang.120: nope Im in the same boat as Mont3core only bought the game a couple of hours ago and have the same exact problem and have completed KOTOR 1 several times without changing anyting

I just found a solution that worked from the thread on KOTOR 1 I deleted the atioglxx.dll file and it run straight away no crash after character creation or anything, funny that I didnt have to do it with 1 but I have to with 2. Now to see if it works when I re-install to get the movies back :)
Just tried this lets me start the game but crashed during loading of the first level
Post edited January 28, 2015 by Aerial_ace
Try disabling Frame Buffer Effects.
avatar
Grimfang.120: nope Im in the same boat as Mont3core only bought the game a couple of hours ago and have the same exact problem and have completed KOTOR 1 several times without changing anyting

I just found a solution that worked from the thread on KOTOR 1 I deleted the atioglxx.dll file and it run straight away no crash after character creation or anything, funny that I didnt have to do it with 1 but I have to with 2. Now to see if it works when I re-install to get the movies back :)
This. So much this. DO NOT GET RID OF THE MOVIES, THEY ARE NOT THE PROBLEM. I just searched in my game file for the atioglxx.dll that he/she is talking about, found it fast and deleted it. Game started immediately with no problems.

THANK YOU SO MUCH!