It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
high rated
If any of you experience issues with running KOTOR 1 in widescreen, try Flawless Widescreen - worked brilliantly with the steam version and was nice and stable too.

You might have to turn that grass off though!

...and some technical sploogery from Spinorial:

avatar
Spinorial: Everyone should use this opportunity to download it and update their plugins. The program works really well, BUT it has its idiosyncrasies and limitations. Here's what I've learned about using it with KotOR (Win8.1, x64, pre-GCN AMD APU):

The 32-bit version works better than the 64-bit one. Use that one, unless your OS prevents you.
The portable versions work as well as the installers.
You'll need to run the game several times to get it working properly.
You shouldn't need any special compatibility settings to run either one, though the setup requires some.

To set up a working solution, I had to set both swkotor.exe and FlawlessWidescreen.exe to Windows XP Service Pack 2 compatibility; FlawlessWidescreen.exe needed to be Run as an Administrator. With FW running, I needed to start the game at least twice because FW had difficulties reformatting the backgrounds and interface in one go. The first time you start the game, change the resolution to your desired one, even if it is already running in it. This will instruct FW to create new interface elements in the Override folder. However, these were still the original 800x600 resources, stretched. I needed to leave the game, then start it again. Now, FW was able to use its resources to copy new background images over the files in the Override folder, and the interface fits perfectly! I was now able to remove all previously applied compatibility settings from either programme. Once the game interface looks properly, it's a good idea to back up your Override folder. Getting a good set of working interface files has always been my greatest difficulty with KotOR.

One caveat to this method was that whenever I changed resolution, the game would revert to full screen. I was still able to use the process to create backgrounds at any resolution. Unfortunately, the in-game interface file only works in full screen; in a window, it gets cut off and is largely unusable.
(personally I didnt have the compatability issues, but thats modern computing for you - always a mystery!).
Hope that helps someone at least.

* * *

OR, you can use UNIWS - http://www.wsgf.org/article/universal-widescreen-uniws-patcher
Seperate instructions provided in this thread by MisterBlack: http://www.gog.com/forum/star_wars_knights_of_the_old_republic_series/widescreen/post25

* * * * *
KOTOR 2:
By editing a 1280x768 resolution into the swkotor.ini file under both [Display Options] and [Graphics Options] it appears to be running fine, fullscreen without any cut off of dialogue or anything else. if you test this method (particularly with any other resolutions, please report back on your findings! :)

NOTE: UNIWS Also works for KOTOR 2, however dialogues are cut off for resolutions under 1280x960.
Hopefully the guy that does Flawless Widescreen will maybe provide a fix for that in the future. I didnt have to do most of what MisterBlack suggests however, just run the UNIWS, find the install directory, set res and patch it, then change the settings in the ini file.
Post edited January 23, 2015 by Sachys
How do you manually tell it where you have the game installed? It seems to be having problems finding mine....
Does the GoG version include widescreen support on its own?
You can also try UniWS and the accompanying HUDfixes from WSGF:

http://www.wsgf.org/article/star-wars-knights-old-republic

EDIT: apparently this doesn't work with the GOG version yet :(
Post edited October 28, 2014 by WiseLearnedMan
avatar
Frugl: Does the GoG version include widescreen support on its own?
It does not.

I really hope the uniws patcher gets updated to support the GOG version. I really don't like running programs in the background whenever I want to play a specific game and nor do I look forward to using a hex editor to modify the exe myself.
avatar
WiseLearnedMan: You can also try UniWS and the accompanying HUDfixes from WSGF:

http://www.wsgf.org/article/star-wars-knights-old-republic

EDIT: apparently this doesn't work with the GOG version yet :(
It did for me. I just had to change the resolution in the .ini file after the patch.
avatar
WiseLearnedMan: You can also try UniWS and the accompanying HUDfixes from WSGF:

http://www.wsgf.org/article/star-wars-knights-old-republic

EDIT: apparently this doesn't work with the GOG version yet :(
avatar
MonsterFish: It did for me. I just had to change the resolution in the .ini file after the patch.
Can you say what settings in UniWS you used to get it to work? It completely failed when I tried.

Edit:

Weird, patch worked this time. I swear it failed spectacularly when I tried earlier today.

So yeah, if you don't want to use the Flawless Widescreen program go here: http://www.wsgf.org/article/star-wars-knights-old-republic
Post edited October 28, 2014 by Enclave996
avatar
Frugl: Does the GoG version include widescreen support on its own?
avatar
Enclave996: It does not.

I really hope the uniws patcher gets updated to support the GOG version. I really don't like running programs in the background whenever I want to play a specific game and nor do I look forward to using a hex editor to modify the exe myself.
Is development of the patch still active? It may not be after all this time.....
Works for me! Make sure you start the game first without the widescreen fix program running or the game won't run.
avatar
yaosio: Works for me! Make sure you start the game first without the widescreen fix program running or the game won't run.
Indeed. Also you may need to change your resolution in-game a couple of times to get it to actually update properly.
avatar
WiseLearnedMan: You can also try UniWS and the accompanying HUDfixes from WSGF:

http://www.wsgf.org/article/star-wars-knights-old-republic
Nice. Works like a charm. I also noticed it even upscales the movies so they play fullscreen rather than switching to a lower resolution. :) Thanks for that.
avatar
king_mosiah: How do you manually tell it where you have the game installed? It seems to be having problems finding mine....
Found this out:
You have to run the game once. After exiting, you open FlawlessWidescreen, select KOTOR and start it directly from your desktop (or wherever). It tells you "injecting", and things work. (for me)
But to be honest, i found it to be a little inscrutable.

Edit:
I had to change the resolution manually in the ini file in the KOTOR dir. Then i started Flawless up again and it worked.
Post edited October 28, 2014 by Prian
avatar
Sachys: If any of you experience issues with running in widescreen, try Flawless Widescreen - worked brilliantly with the steam version and was nice and stable too.

You might have to turn that grass off though!

Hope that helps someone at least.
I remember hearing about the grass performance bug in the PC version, how bad is that? Seems like I remember it affecting either AMD or Nvidia cards, don't remember exactly.
yep flawless widescreen did it for me too, only played half an hour so far, but seems to work fine.
thanks for the tip!
avatar
haydenaurion: I remember hearing about the grass performance bug in the PC version, how bad is that? Seems like I remember it affecting either AMD or Nvidia cards, don't remember exactly.
in my case (and with the steam version) it ground things to a halt - weird "lattice work" glitchyness all over the place.
didnt realise until I left the first planet though - even though there was no grass there, I'd noticed an odd lag. after completing the game I restarted with grass off from the very beginning and had a much smoother experience.