It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
avatar
RebornCdds: Hello,

I installed Kotor 2 with the last version of TSLRCM (1.8.3b) and M4-78EP 1.1B
Everytime I start a swoop race game on Telos, my bike is stuck in the roof and I'm not able to win the race.
I know that this bug was fixed in the officials patchs and I saw a post from a moderator saying that all officials patchs are already included in the game. What can I do now?

Thanks.
I think I know what's going on. I also had a problem with the swoop racing in Onderon. I re-installed the game and the two mods without applying the resolution fix and still got the same issue. So I tried messing with the graphics options. I had Frame Buffer Effects and V-Sync turned ON and I had the problem. Then I left the Frame Buffer Effects ON and turned V-Sync OFF and was able to run my bike on the ground.

So I guess it's V-Sync's fault.

EDIT: Scratch that. It was fine until I completed a race. Then I got teleported to the ceiling when I started a new race. Still in Onderon. @_@

EDIT 2: After finishing all the races in Onderon, I think I know why your swoop bike keeps on swooping upwards: you're clicking too fast. I noticed that if you click too early, you'll send yourself skyward. However, click just before the 1-second mark, and you're good to go.

TL;DR: Click just before the 1-sec mark, and you'll be fine.
Post edited February 09, 2015 by Malfegore_
@ Hassat,

I went last night and uninstalled KOTOR 2 and the mods, went into regedit and did a search for anything related to KOTOR 2 and removed any registry entries i found.

Installed GOG Kotor 2 again, then your v1.8.3b mod then M4 v1.1b mod and started a new game.

Pushed all the way to Telos and still have the swoop bug where swoop goes into the air.

Its frustrating me so much because this is part of game and i cannot play that part.

I even tried putting vsync off like suggested by other user and still no luck.

I really do not know why this is happening because i am just using GOG original game, no cracks or other patches or mods.

Regards to all.
high rated
I cannot believe it, i found the solution, well for me anyways.

I am running the game in Windows XP SP3 compatibality mode and this solved it for me.

Now my swoop is staying down.

I cannot believe i did not try this (probably because game was running fine on all other aspects on my Windows 7 64-bit).

I am speechless that this could solve it and feeling stupid for not trying Windows XP SP3 compatibility mode.

Try this guys and i hope this solves your problem as well and that you can enjoy the game now in ALL aspects.
Let me know.

Regards to all
Post edited February 09, 2015 by lonewolfgk
You are right, enabling XP SP3 compatibility mode worked... I feel fucking stupid as an IT Tech xD
Well, I'm glad I can play this part of the game :)

Thank you all!
NIce find lonewolfgk! I never thought of that either. As you say, all other aspects of the game work fine And explains why it just worked for me in wine. :\ I've seen that issue before when I played it on my old windows machine a few years ago with the cd release, and assumed it was just another thing broken in the game.
avatar
RebornCdds: Hello,

I installed Kotor 2 with the last version of TSLRCM (1.8.3b) and M4-78EP 1.1B
Everytime I start a swoop race game on Telos, my bike is stuck in the roof and I'm not able to win the race.
I know that this bug was fixed in the officials patchs and I saw a post from a moderator saying that all officials patchs are already included in the game. What can I do now?

Thanks.
There is a solution. As soon as the race countdown starts press right/left mouse button frantically a couple of times. This solves the problem.
avatar
lonewolfgk: I cannot believe it, i found the solution, well for me anyways.

I am running the game in Windows XP SP3 compatibality mode and this solved it for me.

Now my swoop is staying down.

I cannot believe i did not try this (probably because game was running fine on all other aspects on my Windows 7 64-bit).

I am speechless that this could solve it and feeling stupid for not trying Windows XP SP3 compatibility mode.

Try this guys and i hope this solves your problem as well and that you can enjoy the game now in ALL aspects.
Let me know.

Regards to all
Thanks man, the swoop issue was really frustrating, but, thanks to your post, I was able do fix it.
avatar
lonewolfgk: I cannot believe it, i found the solution, well for me anyways.

I am running the game in Windows XP SP3 compatibality mode and this solved it for me.

Now my swoop is staying down.

I cannot believe i did not try this (probably because game was running fine on all other aspects on my Windows 7 64-bit).

I am speechless that this could solve it and feeling stupid for not trying Windows XP SP3 compatibility mode.

Try this guys and i hope this solves your problem as well and that you can enjoy the game now in ALL aspects.
Let me know.

Regards to all
avatar
LegateCaesar: Thanks man, the swoop issue was really frustrating, but, thanks to your post, I was able do fix it.
Not a problem, :), glad i could find a solution for myself and everyone else. It was really frustrating and it was so rewarding finding the solution. It was my turn to help others, lol.
Thanks lonewolf. When I first did the Swoop racing on Terlos and won it, everything was fine. The next day I got the swoop on the roof bug out of no where but your fix corrected it.
avatar
lonewolfgk: I cannot believe it, i found the solution, well for me anyways.

I am running the game in Windows XP SP3 compatibality mode and this solved it for me.

Now my swoop is staying down.
Want to hear something funny? I'm running the game in XP SP3 itself, and I still have this bug!

Haven't been able to fix it at all, despite trying lots of things.
avatar
thebream: Thanks lonewolf. When I first did the Swoop racing on Terlos and won it, everything was fine. The next day I got the swoop on the roof bug out of no where but your fix corrected it.
I am glad it helped, it is a very frustrating bug, lol. Now you can enjoy it. :)
avatar
lonewolfgk: I cannot believe it, i found the solution, well for me anyways.

I am running the game in Windows XP SP3 compatibality mode and this solved it for me.

Now my swoop is staying down.
avatar
UniversalWolf: Want to hear something funny? I'm running the game in XP SP3 itself, and I still have this bug!

Haven't been able to fix it at all, despite trying lots of things.
I am sorry to hear you still having this problem, but my fix was for people running better (later) operating systems like Windows 7, 8 or 8.1.

I have no idea why you are struggling on Windows XP operating system because other XP users did not have the issue.

Are you using GOG version (just asking to make sure). I know there were people saying they had old disc version and keeping disc in drive solved it for them but this was years and years ago.

I hope you get it fixed.

Regards :)
Post edited May 16, 2015 by lonewolfgk
avatar
lonewolfgk: I have no idea why you are struggling on Windows XP operating system because other XP users did not have the issue.
That's what I gathered from your previous discussion, since XP comp mode made it work. No idea why it's a problem for me. Sounds like it's always been a somewhat mysterious bug.

It's the latest GOG.com version. I just bought it in the recent sale bundle.

I haven't tried too hard to fix it yet (I just skipped the racing because it's not a huge part of the game anyway), so there's still hope I'll find a solution. If I do, I'll post it here.
I have this issue as well. It seems to happen if one gears up before the countdown ends. If you do it a bit later, everything will work fine.