It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Hello,

I installed Kotor 2 with the last version of TSLRCM (1.8.3b) and M4-78EP 1.1B
Everytime I start a swoop race game on Telos, my bike is stuck in the roof and I'm not able to win the race.
I know that this bug was fixed in the officials patchs and I saw a post from a moderator saying that all officials patchs are already included in the game. What can I do now?

Thanks.
Do you use an widescreen "mod"?
If so, there's your answer why it happens.
Nop, only TSLRCM and M4-78EP.
avatar
RebornCdds: Nop, only TSLRCM and M4-78EP.
Same problem here,

I have GOG version,
Installed TSLRCM v1.8.3 mod and M4-78EP11 mod
Noticed Swoop bug on Telos.
Searched for answers, found lots of people complaining about this since game release in 2005.
Noticed new versions of both mods.
Downloaded them again in the hopes it would fix swoop race bug.
Installed TSLRCM v1.8.3b over v1.8.3 (asked if i could, Hassat confirmed that i could just install over it since my version is v1.8.3)
Installed M4-78EP11b over v1.1 (again confirmed by Hassat that i could)
Loaded save game and still have swoop problem on Telos.

I have no other exe files copied over original swkotor2.exe and no other mods installed.

It seems like i will have to miss out on the swoop races since there is no fix for it, which is a pity because i like to do everything in the game i can, but anyway i will just have to miss swoop races and carry on.

Regards to all
Judging from Hassat's comments I would say that to work this problem you should look into monitor/vid card & settings/aspect settings in kotor. What are you guys doing similarly, that you've managed to resurrect a dead bug?

To start: In the kotor ini file in the two places where the aspect is specified (width and height), what do you guys have? What monitors? What vid cards?
avatar
alcaray: Judging from Hassat's comments I would say that to work this problem you should look into monitor/vid card & settings/aspect settings in kotor. What are you guys doing similarly, that you've managed to resurrect a dead bug?

To start: In the kotor ini file in the two places where the aspect is specified (width and height), what do you guys have? What monitors? What vid cards?
Hi alcarey, well i have highest resolution that game can handle inside its own settings which is 1024x1280.
I am not running any widescreen patches or mods, the 1024x1280 is the setting in game in graphics option.
I am running a GTX580 graphics card (Nvidia) and v344.75 of their software.

I have Samsung 21" Monitor on this pc that i use to play the game.

Why would graphics settings influence a swoop race in game but rest of game fine?

I tried setting game on 800x600 and still doing the bug hanging in air. I tried setting all graphics on lowest and untick all options to turn graphics off. Still doing it, so does not matter if it is highest setting with all options or lowest graphics with all options off, still doing it.

I tried 1024x768 and still bug remains.

This is not a cracked version (because i see lots of people saying this on internet if using pirate version of game causes the problem), this is GOG game with the 2 mods mentioned above, no other mods or patches installed.

Any other help would be appreciated.
Post edited February 07, 2015 by lonewolfgk
When you modify the height-x-width, you are using the options to do so, or you are editing the ini file? Have you ever edited the ini file?

Have you ever had kotor installed on this machine before?

You want to know why something? Heck if I know. To solve one of these you have to bang around trying things out - especially not leaving out the things that you are absolutely certain could not be creating the problem. At least, that's my philosophy. (Well, my first choice is to do what other people have done to solve the same problem. But you've already done that: your version of the game is patched already... unless you have a surprising answer to my third question, above).
avatar
alcaray: When you modify the height-x-width, you are using the options to do so, or you are editing the ini file? Have you ever edited the ini file?

Have you ever had kotor installed on this machine before?

You want to know why something? Heck if I know. To solve one of these you have to bang around trying things out - especially not leaving out the things that you are absolutely certain could not be creating the problem. At least, that's my philosophy. (Well, my first choice is to do what other people have done to solve the same problem. But you've already done that: your version of the game is patched already... unless you have a surprising answer to my third question, above).
Again thanks for the reply and trying to help.

No i never edited this file, i just chose display settings inside the game at the graphics options. That was the highest display (1024x1280) the game offered to me.

No kotor 2 was never installed on this machine.

Thanks again for trying.
In contrast, I edited GoG's .exe with the UniWS patcher available at the wsgf.org site. edited the swkotor2.ini with my display settings and downloaded the appropriate HUD file for the override folder (16:10 for me with 1680x1050) and everything (including swoop racing) works just fine in the high resoultion! (I'm running it in a crossover wineskin engine on my mac though)

I heard that the Squizzy Patcher available uses and older version of the .exe, so I avoided that. which could have easily used a version prior to the update.

This is all with Gog's version of Kotor II plus TSLRCM 1.8.3b + the latest M4-78EP11b. (clean install)
Post edited February 08, 2015 by herecomethe2000
I was able to play the swoop race without the bug by loading the auto-save when you enter for the first time the entertainment module 081 before claiming your stuff at the TSF.
When I claimed everything and got back to the cantina, the bug was back.

I never edited the .ini file, I'm running on 800*600 with max graphic options.
avatar
RebornCdds: I was able to play the swoop race without the bug by loading the auto-save when you enter for the first time the entertainment module 081 before claiming your stuff at the TSF.
When I claimed everything and got back to the cantina, the bug was back.

I never edited the .ini file, I'm running on 800*600 with max graphic options.
Is your system similar to the one @lonewolf is using, in any way? (other than having the same bug, I mean)
Nop:
-GeForce 210 card (software 335.23)
-24" Gateway monitor.
-8gb ram
-intel i5-2300 cpu 2.80 GHz
Why do poeple install 1.8.3 first and then 1.8.3b? The 1.8.3b version I found on moddb was all inclusive. That could be the problem. People should just install 1.8.3b on a clean install.
avatar
herecomethe2000: Why do poeple install 1.8.3 first and then 1.8.3b? The 1.8.3b version I found on moddb was all inclusive. That could be the problem. People should just install 1.8.3b on a clean install.
While i appreciate your reply i would recommend you read again what i wrote first before commenting like that.

I said that i installed v1.8.3 and ALREADY had that problem with swoop bug, i installed v1.8.3b with the hopes of it solving that and no luck.

So it was not working fine and then all of a sudden have this bug, i had this already before i installed v1.8.3b over 1.8.3.

Regards
Is the save function available, when you are "stuck in the roof"? If so, try saving and restoring at that point.