It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Hi guys. I have an issue with KOTOR 1. My laptop has a 120Hz refresh rate and I am unable to lower it. Also when I start game, it is in a small window and am unable to change resolution, as no resolution options are listed in the game options menu. Has anyone else experienced this and/or know a fix? Any help greatly appreciated :)

Below are link to images:

http://imgur.com/Hs87lA0
http://imgur.com/iYylkhS
http://imgur.com/E9KHBUg
http://imgur.com/QmxFpKp
Post edited August 20, 2017 by Skeet8385
No posts in this topic were marked as the solution yet. If you can help, add your reply
Looking at the ini file, the resolution is set to 1920x1080: have you edited the file yourself?
avatar
Skeet8385: Hi guys. I have an issue with KOTOR 1. My laptop has a 120Hz refresh rate and I am unable to lower it. Also when I start game, it is in a small window and am unable to change resolution, as no resolution options are listed in the game options menu. Has anyone else experienced this and/or know a fix? Any help greatly appreciated :)

Below are link to images:

http://imgur.com/Hs87lA0
http://imgur.com/iYylkhS
http://imgur.com/E9KHBUg
http://imgur.com/QmxFpKp
At least for the purpose of playing older games, change your desktop resolution to a standard one that older games can recognise. My guess is that (as this is an old game) when KotOR scans your hardware it does not recognise what it finds, hence no graphic resolution options. You could also try starting in Windowed mode and the switch to full screen by ALT+ENTER.
Before you try and mod the game to widescreen I would try and see if it will even run the standard resolutions @ 120Hz.
I would edit your swkotor.ini with refresh rate=120 and your height =768 , width= 1024

Then in the Nvidia Control Panel under Adjust desktop size and position set Perform scaling on: GPU and tick Override the scaling mode set by games and programs.

If the game will run @ 1024x768 120Hz (It may not) then at least you stand a chance of patching your .exe with the UniWS mod. Disc or GOG version, not your Steam version.