It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Let me start by saying I have both the Steam and GOG versions currently installed. The Steam version broke with a recent Catalyst update, so while it will launch to the menu it will crash when attempting to start the game engine by loading a save or starting a new game.

I picked up the new GOG version hoping it'd help with this and when the executable is run it just crashes in the background, and never actually launches, which I've verified through Flawless Widescreen's monitoring program.

The usual modifying config file for windowed mode, etc. doesn't influence either of these.

My Desktop is currently:
-Windows 8.1 64-bit
-AMD FX 8350
-16GB of DDR3 RAM
-Soundblaster Z (ALchemy enabled on Steam version)

-Sapphire AMD R9 285 w/ Catalyst 14.9 driver (Steam version worked up to 14.7 beta driver)
I verified the 14.9 driver break of the Steam version occurs with both my desktop and A10 powered Windows 7 (x64) laptop. The R9 285 I recently installed however requires Catalyst 14.9 or newer.

I've tried a few OpenGL->DirectX wrappers that support KOTOR to check if this was a OpenGL 1.4 issue on the Steam version, and the behavior is exactly the same. Return to Castle Wolfenstein, and other OpenGL games however work fine off the driver, and the Knights of the Old Republic games seem to be the only ones effected by this.

[-]

On further tinkering. If you rip out the atioglxx.dll it behaves like the Steam version, aka it'll let you get to the menu, the engine works through character creation, and it crashes the second it tries to start the actual engine at the end of the load bar. Based on prior experience tinkering associated with the atioglxx.dll library that half of it is due to it being an older OpenGL driver that doesn't support the R9 285, but KOTOR seems to be the only game that doesn't just work with that library insert deleted forcing the game to use the normal driver library.

Modifying the config file doesn't appear to actually shift it to windowed mode on the GOG version like it does with the Steam version.

I respect part of this is on AMD's side as Catalyst 14.9 broke things with KOTOR's engine for some reason, and I've filed a ticket with them. I however also respect that the R9 285's architecture is AMD's new architecture that they'll be using in their next card series, and the inserting an old OpenGL library trick looks like it's going to break.

I'm going to test on the laptop, and check back on results.

EDIT:
It works fine on my Trinity laptop. so for the moment is basically an issue specific to the R9 285's architecture and related support.
Post edited October 29, 2014 by Batou456
No posts in this topic were marked as the solution yet. If you can help, add your reply
WindowMode is possible in the GogVersion after start via Alt+Enter.