It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
So i was crashing out of nowhere and started looking into everything. The release notes for Nvidia's drivers 350.12 say this:
Star Wars: Knights Of The Old Republic 2–the game fails to launch, and an
“application has stopped working” error message appears. [420115]
This occurs because the application is not able to interpret the driver version correctly
So i moved back a version and everything has started working again. Hopefully this helps anyone rocking an Nvidia card. If anyone found a way to et it working on these drives, i would be thankful. They gave me some decent rate increases.
Is this after playing for some time, or at launch? I'm on 350.12, and I can play for a few minutes (for testing) without issue.
avatar
Hickory: Is this after playing for some time, or at launch? I'm on 350.12, and I can play for a few minutes (for testing) without issue.
So this was on my 770 system it crashed, on my wife's 660 system it works with these drivers... maybe i have a rogue file or bad install i'll clean out my drivers and install from the ground up and let you know.
Hmm, it still works for me (GTX 770, 350.12 drivers, Windows 7 64-bit). I've played through several planets since the driver released without noticing any new problems.

I'm using the CD version of the game with the following

1.0b official patch
HQ movies and music patch
The Sith Lords Restored Content Mod 1.83B
M4-78 Enhancement Project 1.1B
Widescreen solution from PCGamingWiki - 1920x1080
Fullscreen movies solution from PCGamingWiki

Running swkotor2.exe in XP Service Pack 3 compatibility mode
8x MSAA and 8x Transparency Supersampling forced through Nvidia Control Panel (in-game AA set to off)
In-game graphics settings all set to high / enabled
In-game v-sync on, triple buffering forced through Nvidia Control Panel
"Threaded Optimisation" setting in the Nvidia Control Panel set to "off" for KoTOR 2
"Disable Vertex Buffer Objects=1" added under "[Graphics Options]" in swkotor2.ini

I've had a few crashes throughout the game (before and after 350.12), quite rare though.
Only really annoying issue I've had is losing keyboard controls every time a movie plays or if I alt-tab out of the game - which can be fixed by manually saving the game (or just bringing up the input box to name a save file).
Post edited May 18, 2015 by DreadMoth
avatar
DreadMoth: Only really annoying issue I've had is losing keyboard controls every time a movie plays or if I alt-tab out of the game - which can be fixed by manually saving the game (or just bringing up the input box to name a save file).
Try turning VSync on. This worked around a bug in KOTOR1 where the movement keys would not work after combat finished. It sounds like a similar issue.