It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
I've come across a bug that I don't remember seeing when I played this game on my Xbox many years back.

After I destroy one the droids I can't move my character. The game doesn't accept my movement commands. Sometimes it takes awhile before it will accept movement commands again after combat. Other times it doesn't start accepting movements commands again period.


Has anyone seen this glitch before?


For the record I have TSLCRM and the new planet mod installed.
This question / problem has been solved by Vythonautimage
It may have something to do with V-Sync. Try to enable it via the graphics options & report back!

ps. If it is already enabled, try to disable it to see if this fixes your problem...
Post edited February 10, 2015 by Vythonaut
Enable V-Sync
What others said, enable v-sync.
I had this issue near the start of the game - quicksave and quickload sorted it in the short term, and then it just stopped by itself.
avatar
Vythonaut: It may have something to do with V-Sync. Try to enable it via the graphics options & report back!

ps. If it is already enabled, try to disable it to see if this fixes your problem...
Enabling V-Sync Fixed the issue.

Thank you to everyone who responded.
Post edited February 11, 2015 by auroraparadox
Just came here to look for anything on this issue (as I've just started playing and also have it).

Will try the V-Sync thing...


[edit]:

Yep it works for me as well :)

Although sometimes if I am in Stealth mode when a battle starts (which then causes the automatic drop-Stealth when the fight starts) - then when the battle ends I am stuck. I have found that toggling Stealth On / Off gets me moving again.

If I want to toggle Stealth back on after the battle ends, and I am "stuck" (as noted previously), then I can't just turn Stealth On to get moving. I have to toggle On / Off / On to get Stealth back on AND be able to move. When I do not have V-Sync on, that sequence does not get me moving. So it seems that V-Sync On fixes the issue except sometimes when using Stealth mode, I ALSO need to do that toggling thing. But V-Sync On is needed for that Stealth toggling to work.
Post edited February 13, 2015 by Martek
avatar
auroraparadox: I've come across a bug that I don't remember seeing when I played this game on my Xbox many years back.

After I destroy one the droids I can't move my character. The game doesn't accept my movement commands. Sometimes it takes awhile before it will accept movement commands again after combat. Other times it doesn't start accepting movements commands again period.

Has anyone seen this glitch before?

For the record I have TSLCRM and the new planet mod installed.
A better solution for this problem for me than enabling V-sync was simply limiting frame rates to 60fps through nvidia inspector or equivalent program. V-sync reduced the graphical quality of the game by enabling strange stuttering. However I do experience some tearing which is odd given I have a 144hz g-sync enabled monitor.

Edit: This fixed the tearing for me while fixing the 'stuck' problem as well as maintaining 60 fps:

"So after monkeying around with NVIDIA inspector, I finally managed to correct the issue.

After launching NVIDIA Inspector, I clicked on the settings icon (next to the driver information), and selected "Star Wars: Knights of the Old Republic 2" from the drop-down menu.

From there, I went to the "Sync and Refresh" section.

Under there, I set the Vertical Sync Tear Control to "Adaptive" (not strictly necessary to fix the problem).

The last option that I altered was Vertical Sync - which I set to "1/2 Refresh Rate."

This is what fixed the problem.

I now no longer have tearing, though I do feel some slowed frame rate. It's not enough to affect the gameplaying experience, and it's loads better than having a nasty tear all the way through the screen.

Just wanted to post this up here in case anybody else ever ran into this problem."
Post edited February 14, 2017 by Gr1mT1ckler