It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
It's as the title says. I can launch the game and create a character, but when I click play the game crashes after a loading screen. I own all three versions (this, Steam, and the original retail with like five discs.) and have had this problem with the Steam version as well. I haven't tried the retail but I doubt it would help anything. I tried installing TSLRCM to no avail. I also disabled my widescreen fix to no avail. I'm running Windows 7 64 bit with an ATI GPU on the latest drivers. Any help would be greatly appreciated.
high rated
Fixed my self by disabling frame buffer effects.
avatar
4gateftw: Fixed my self by disabling frame buffer effects.
Thank you. Did the same and the game now works. The only thing that made this game playable to me... Kreia, here I come, once more...
Same for me, only way to make it work, but after disabling frame buffer effects i had a black screen but the game was still running, had to quit using sound to know where click and then re start. Now every change in graphism option give me a black screen ! But the game works ^^
so thanks !
Post edited June 30, 2015 by flowright-fye
Where do I find the Frame Buffer?
options/graphics/advanced options/frame buffer effects
avatar
alcaray: options/graphics/advanced options/frame buffer effects
same issue but i cant select frame buffer
avatar
alcaray: options/graphics/advanced options/frame buffer effects
avatar
maxpowers25: same issue but i cant select frame buffer
You can try editing your swkotor.ini file. Set "frame buffer = 1" to "0" (or vice versa, depending on what you find when you look at it).

However, when the game does not offer you options to change settings, then that means the game does not think your rig has the ability to make use of that option. So often, doing it manually has no effect. Still worth a try.

What kind of PC and graphics card are we talking about?
KotOR II (Star Wars - Knights of the Old Republic II - The Sith Lords) *still does not work*

I have tried *everything*, from making changes in the .ini file to cancelling frame buffer effects.

I have also tried running it as administrator.

I have also tried changing the affinity (from the Processes tab of the Task Manager).

****These are just examples of what I tried****.

I am running Windows 7, 64 bit.

Stilll, the game does not work.

IMPORTANT: By "the game does not work" I mean that it crashes right after character creation.

I have also tried renaming the .bik files.

And so on.

I play games old and new on my computer, so I really don't think it is my computer that is the problem.

I have also tried downloading varios patches for KotOR 2. Still nothing.

Any good advice please? PLEASE?
Post edited April 28, 2017 by costrav
avatar
4gateftw: Fixed my self by disabling frame buffer effects.
Hey, thanks for this. Got my game to work now.
avatar
4gateftw: It's as the title says. I can launch the game and create a character, but when I click play the game crashes after a loading screen. I own all three versions (this, Steam, and the original retail with like five discs.) and have had this problem with the Steam version as well. I haven't tried the retail but I doubt it would help anything. I tried installing TSLRCM to no avail. I also disabled my widescreen fix to no avail. I'm running Windows 7 64 bit with an ATI GPU on the latest drivers. Any help would be greatly appreciated.
swkotor.ini fix worked- turning off frame buffer (changed 1 to 0). Thanks all!
Disabling frame buffer effects fixed this problem for me as well, in both KOTOR1 and 2.

Windows 8 ATI GPU system.

Maybe this should be added to the sticky list of fixes for this game?