It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
This issue has been plaguing me for all versions of Kotor 1 since I got a new computer. The computer freezes completely, though the music is still playing. I have looked and looked and can't find an adequate solution to this issue. Can anyone help?

I have tried to attach my dxdiag information to this message as well as cutting and pasting and it is not working. Sorry about that.
avatar
jbeck83:
can you be more descriptive?
- ie is it freezing with a black screen after movies? - randomly? - can you even get into the game etc?
avatar
jbeck83:
avatar
Sachys: can you be more descriptive?
- ie is it freezing with a black screen after movies? - randomly? - can you even get into the game etc?
It seems to be random, but I have not yet been able to get off of the Endar Spire. No, the game itself just freezes. The character freezes, I cannot move the mouse, I can't push escape and go into the game menu or anything. It literally just freezes, yet the music keeps playing.

Thanks for your help!
Not sure if this will help, because it's not quite the same problem, but it can't hurt to give it a shot. Ive experienced freezing myself after combat (although unlike you, I was still able to access the menu). This was solved by turning V-Sync on. You might want to try checking if you've got that setting enabled. Again, I don't know if it will help, but it might.
Post edited January 22, 2015 by FearfulSymmetry
avatar
Sachys: can you be more descriptive?
- ie is it freezing with a black screen after movies? - randomly? - can you even get into the game etc?
avatar
jbeck83: It seems to be random, but I have not yet been able to get off of the Endar Spire. No, the game itself just freezes. The character freezes, I cannot move the mouse, I can't push escape and go into the game menu or anything. It literally just freezes, yet the music keeps playing.

Thanks for your help!
you mean like a laggy freeze - or the game hangs? - it might be worth adding the game to DEP exceptions
I turned V-Sync on, updated my video drives, and added swkotor.exe to my exceptions in the firewall.

I e-mailed GOG support and they gave me a list of things to do, but it sounds like it's just a "let's cover our bases" list.

The latest thing I noticed is that I can still move the mouse around when it freezes. The last time, it happened when a "journal entry added" screen came up and I found I couldn't click out of the box. I couldn't move anything,

I didn't have any problem like this on any other computer (though they all had their problems). I am using an NVidia GTX 770 on Windows 7 x64.

And why on earth is this forum not letting me attach a freakin' text file?! :/

Thanks again for all of your help.
avatar
jbeck83: And why on earth is this forum not letting me attach a freakin' text file?! :/
Attach it as an image - change the file extension from .txt to .jpg, .png or .bmp.

Also, I see you have nVidia GPU - try to unistall Geforce Experience if you have it installed.
avatar
jbeck83: The latest thing I noticed is that I can still move the mouse around when it freezes. The last time, it happened when a "journal entry added" screen came up and I found I couldn't click out of the box. I couldn't move anything,
have you tried doing a quicksave / quickload? - ive had the issue of my character "sticking" after combat and that sorts it out.
Yeah. So is GeForce Experience typically bad news? I haven't seemed to have any trouble with it up to this point. That could be the issue. I will try it.

The combat sticking is a separate issue, which I have experienced in the past but have yet to experience in this build. Essentially, it is the same thing, except in this case I do not have GUI access; for instance, I can't tab between characters, access the journal/inventory screens, or <esc> out of the program.

Thanks for all your help. I'll let you know how it goes.
OK. Tried reinstalling GeForce experience, but no dice. Also tried disabling frame buffer effects in the graphics menu. I got a bit further into the tutorial, but only by a little bit.

Another thing that the customer rep suggested was that I revert back to the DirectX 2010 drivers. I'm not sure - going three years back might prevent me from playing other games...

I also noticed one person on the steam forums with the same series of cards I have (700x) is experiencing the same problem.

Does anyone have any more ideas? I really want to play this game! Thanks again for all of your help.
You need to *UN*install GeForce Experience. It causes all sorts of problems with all sorts of games. You do not need it if you aren't using it.

*edit* And the sticking after combat problem is often fixed by toggling the vsynch setting. Save/load is far too annoying a solution for me to deal with. I don't have that kind of patience.
Post edited January 23, 2015 by alcaray
Sorry, that's what I meant - I did uninstall Geforce Experience. it didn't fix the problem. Also, VSync is enabled.

Thanks again!
Bump! Anyone? Is this problem limited to this particular series of video cards? Should I really try to roll back to the 2010 directx drivers?
avatar
jbeck83: Bump! Anyone? Is this problem limited to this particular series of video cards? Should I really try to roll back to the 2010 directx drivers?
I did some searches but could not find anything to suggest. I have not tried old obsidian forum (does it still exist?).

-edit- I have a GTX 650 Ti and it works fine for me.
Post edited January 24, 2015 by alcaray
avatar
jbeck83: Bump! Anyone? Is this problem limited to this particular series of video cards? Should I really try to roll back to the 2010 directx drivers?
avatar
alcaray: I did some searches but could not find anything to suggest. I have not tried old obsidian forum (does it still exist?).

-edit- I have a GTX 650 Ti and it works fine for me.
Thanks. I think I may have fixed the problem - I turned anti-aliasing down to two, and no crashes yet. Granted I only played for about ten minutes, but it would always freeze about two minutes of playtime. Are there any known problems with turning AA up to a high level? Mine was previously set on 8x.

Thanks again for your help!