It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Hello all,

I'm having quite a bit of trouble with this game. The CD version has the built-in DRM issue that I'm not really motivated to work around, so seeing it available DRM-free here got me all excited. Hopefully someone can help me out.

Over the years I've researched extensively on how to get the game running with Windows 10, so I'm very much aware of the OpenJK thing. (Not going to lie, it's a little disappointing that the Switch got a remastered version while PC players are stuck with the same issues as the original CD release.)

I currently have opengl32.dll in my GameData folder and the game *does* start, at least when it feels like it. There's now a second issue that makes it equally unplayable.

At some point - whether immediately after opening, immediately after reaching the menu, or after clicking on a menu item - it will "crash". Now, this isn't a full crash. My screen returns to the desktop but the JK:JA process remains open in the background. If I Alt+Tab to it, or simply click on the taskbar icon, it will present a black screen, but mousing around makes the menu sound effects play. So from what I've gathered, the game's running, but essentially invisible.

I've tried multiple fixes for this. The following is what I've done, to the best of my memory:

1. Installed DirectX End-User Runtime directly from Microsoft website (in hopes that this was an overlooked fix somehow)

2. Added "-w" (minus quotation marks) to the end of the shortcut target in its Properties popup

3. Run jasp.exe in compatibility mode for Windows XP SP2 and SP3 (also changed jamp.exe settings just in case)

4. Adjusted other compatibility settings: 640x480, reduced color mode, fullscreen optimizations, run as admin

5. Attempted to adjust high DPI settings (very little available for me to play with, most likely due to Intel HD Graphics)

6. Changed resolution settings with the game console (oddly enough this worked perfectly, so now I can at least see a widescreen title card!)

7. Tried a fix from jkhub.org that involved changing Windows settings to "best appearance" in System->Advanced system settings->Performance settings->Visual Effects

8. Adjusted "r_primitives" setting in the game console (tried 1, 2, and 3, restarting after each change, no success with each)

I am unable to adjust my DirectX settings in dxdiag and also can't do much more with my graphics settings. Incidentally, I can play Star Trek Voyager: Elite Force with no issue (from an original CD release, no less).

Processor specs: Intel Core i5-3340M 2.70GHZ
I have 12GB RAM.

If anyone has fixes, or at least ideas, please do let me know.
No posts in this topic were marked as the solution yet. If you can help, add your reply
I suppose you got the fix for Intel Graphics from here, hence I suggest you to take the advice of the author of the patch and contact them directly on Discord here, explaining the issue you have with the game.
Post edited December 29, 2020 by dr.schliemann