It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
high rated
Worked for me with some trial and error, maybe will help with others.

In doing some research, it seems that the game had issues with memory management. I vaguely remember this the first time around years ago.

What has helped me the most is putting the game into compatibility mode for Windows 98/ME. This does have one peculiar side effect of moving the savegame folder the game is looking for from:

\Users\{username}\AppData\Roaming\Petroglyph\Empire At War\Save
to
\ProgramData\Petroglyph\Empire At War\Save

With this in mind, you'd need to move/copy your existing savegame files.

I'll note it doesn't fix the issue completely, but it sure works a heck of a lot better.
I also think i found a solution that makes the game run better

1) Go to Star Wars - Empire at War folder and enter the Gamedata folder of the game

2) In the Gamefolder left click the Sweaw.exe and choose Properties

3) Choose Compatibilty tab and then "Change Settings for all Users"

4) Remove the marked option that says 'Disable scaling on High DPI settings" (that should enable the Display scaling)

5) Click Apply and then run the game by clicking the Sweaw.exe (and not from the shortcut)

After that my game seems to run much better
Post edited February 07, 2015 by Manos12
avatar
puppysnuff: Worked for me with some trial and error, maybe will help with others.

In doing some research, it seems that the game had issues with memory management. I vaguely remember this the first time around years ago.

What has helped me the most is putting the game into compatibility mode for Windows 98/ME. This does have one peculiar side effect of moving the savegame folder the game is looking for from:

\Users\{username}\AppData\Roaming\Petroglyph\Empire At War\Save
to
\ProgramData\Petroglyph\Empire At War\Save

With this in mind, you'd need to move/copy your existing savegame files.

I'll note it doesn't fix the issue completely, but it sure works a heck of a lot better.
Putting it into compatibility mode for 98/ME is the only way I've got the game to run properly. Thank you.
I don't know why but without it the game runs right maybe the first time after rebooting and then goes haywire after you load another saved game or whatever.

Putting it into compatibility mode for 98/ME is the only way I've got the game to run properly. Thank you.
I don't know why but without it the game runs right maybe the first time after rebooting and then goes haywire after you load another saved game or whatever.
Glad I could help.
I really hope this works to fix the stutter issues.

I have the game on Steam but it stutters and just performs undesirably.

But due to some issues I can't get my Steam to download games lately :/

So maybe some time I will pick up EAW on GoG and try this Win 98 Compatibility fix.

Win 7 x64
Post edited March 12, 2015 by vince0018
avatar
puppysnuff: Worked for me with some trial and error, maybe will help with others.

In doing some research, it seems that the game had issues with memory management. I vaguely remember this the first time around years ago.

What has helped me the most is putting the game into compatibility mode for Windows 98/ME. This does have one peculiar side effect of moving the savegame folder the game is looking for from:

\Users\{username}\AppData\Roaming\Petroglyph\Empire At War\Save
to
\ProgramData\Petroglyph\Empire At War\Save

With this in mind, you'd need to move/copy your existing savegame files.

I'll note it doesn't fix the issue completely, but it sure works a heck of a lot better.
Thankyou for this and for the new save directory which it switched my old save to. Now, instead of each battle taking a minute or two to load it takes about a second and instead of the stutter show I had in battles it is now silky smoothness! Now I can really rule the Empire!

Changing to Win\98 did it finally, although i did install Alchemy for the Creative sound and some special 2mb patch, but they didn`t really make the major change like the Win\98 thing has.
avatar
Socratatus: Thankyou for this...
Happy to help. May the Force be with you.
Just thought i would let you guys know:

Removing the tick for Disable Scaling on High DPI Settings and running in Win 98/ME fixed my stuttering issues on Windows 10.

Thanks for this guys!

4Dyce.
Cheers guys for the info,, was stuttering really bad on Win8.1 for me but now it's running good..

THANKS :)
Worked for me too. Maybe someone should sticky this?
avatar
puppysnuff: Worked for me with some trial and error, maybe will help with others.

In doing some research, it seems that the game had issues with memory management. I vaguely remember this the first time around years ago.

What has helped me the most is putting the game into compatibility mode for Windows 98/ME. This does have one peculiar side effect of moving the savegame folder the game is looking for from:

\Users\{username}\AppData\Roaming\Petroglyph\Empire At War\Save
to
\ProgramData\Petroglyph\Empire At War\Save

With this in mind, you'd need to move/copy your existing savegame files.

I'll note it doesn't fix the issue completely, but it sure works a heck of a lot better.
It's worked, thank you!
For me, limiting my FPS into 60 solved all my stuttering and lagging problems.
When I try any compatibility mode prior to vista the game just fails to start, no error or anything it's just like I never started the game. With Vista and other solutions I can't get rid of the lag, for either the core game or expansion. Anyone else experiencing this issue?
avatar
zazu49: Worked for me too. Maybe someone should sticky this?
I concur. Worked for me. Perfect advice, thanks.
It worked for me with the main games, but mods still have the stuttering problem (I know Republic at War has).