It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Hello, everyone.

I have been having a big issue that no one seems to know how to fix. Months ago, I ordered the Star Wars: Empire at War Gold Pack off Amazon. It arrived and worked fine on my Windows 7 Professional computer with no issues or problems whatsoever. I happily installed and played various mods, keeping track of which ones changed base game files, like Republic at War. However, one day, I loaded a mod like normal and I was all set to play. Then I clicked "skirmish". The game crashed to the desktop with the error message "Star Wars: Empire at War (TM) - Forces of Corruption (TM) has stopped working. Windows is checking for a solution to the problem." That message. You know the one I'm talking about. Just substitute the game for any program. Windows does its thing, and as it usually does in those instances, it finds no solution, so the only option is to close the program.

Anyway, thinking it's the mod's fault, I shrug and load up another mod. Again, I click skirmish, crash to desktop, same message. Another mod, and another, all the same thing. So, believing that the issue is with the mods, I begrudgingly load up the base game. I click skirmish, and what do you know? Crash to desktop. Same. Message.

I look online for a solution, but all I see is people having the issue of the game crashing because of a security module or exception error. I never got those error messages. So I tried re-installing. Didn't work. I tried re-installing and not putting mods on. Didn't work. Then I find that the GoG version has no issue with crashing, so I go ahead and buy that, putting my disk version away and deleting it's files.

Yay, it works! With mods, too! Nothing could possibly ruin my fun now! However, one day, I loaded a mod like normal and I was all set to play. Then I clicked "skirmish". The game crashed to the desktop with the error message "Star Wars: Empire at War (TM) - Forces of Corruption (TM) has stopped working. Windows is checking for a solution to the problem." Am I repeating myself? Because I am. The same issue that happened disk version happened with the GoG version. On the bright side, the game works flawlessly when I uninstall and re-install it, mods or no. But all it takes is a day or so, sometimes even hours, and the same problem comes up. The only solution I've found is uninstalling and re-installing the game. There has to be a permanent solution so I don't have to keep doing this.

I know you'll be wanting specs, so here they are:

Windows 7 Professional
Intel Core i5-5200U CPU
8GB RAM
64-bit Operating System

HOW DO I FIX THE CRASHING?
No posts in this topic were marked as the solution yet. If you can help, add your reply
avatar
commander6147: snip
HOW DO I FIX THE CRASHING?
few suggestions if you run again into this problem.

Antivirus maybe causing it? (disable and try again)

How do you start swfoc? I use for my 20 odd mods bat - files and never had a problem (W8.1)

Permission rights for the save game location? (Windows might change it, location depends on your OS and compatibility settings in use)

Registry changes ? Do you use something like regcleaner or similar which might remove the entries? Check after a fresh install and after crash if there are any changes.
Same problem here but even several reinstallations didn't solve it.
avatar
Aphain: Same problem here but even several reinstallations didn't solve it.
Aphain,

a wee bit more information would be useful ;)

EIn bisschen mehr Info wuerde da helfen.....

Ich bin gerne bereit ein bisschen meiner Freizeit zu opfern, aber..........;)
Hi,

Ok, das Problem ist so ziemlich das gleiche wie beim Kollegen von oben:

Sobald ich bei Forces of Corruption auf den "Skirmish" button klicke, stürzt das Spiel ab.

Wenn ich das Grundspiel spiele, funktioniert der Button seltsamerweise ganz normal. Ich kann
auch in beiden Versionen die Kampagnen und die GCs ohne Probleme spielen - die Gefechte
funktionieren dann sowohl auf dem Boden als auch im All. Ich habe das gleiche Problem sowohl
bei der GoG als auch der Steam Version des Spiels - mehrfaches neu-installieren hat bei beiden
absolut nichts gebracht. Alle meine Treiber sind up-to-date und auch alle Windows 10 Updates sind
installiert. Das Problem ist irgendwann kurz nach dem Update der Steam Version aufgetreten, nachdem
ich, wie der Kollege über mir, mehrere verschiedene Mods installiert hatte. Das löschen der Mod-Dateien
hat allerdings nichts gebracht - ich denke auch nicht, das es an den Mods liegt, da die GoG Version
ebenfalls nicht funktioniert, obwohl ich dort nie Mods installiert habe.

Grüße, Aphain
avatar
Aphain: snip
Hi Aphain,

Grundpiel? Was meinst du damit? Doch nicht Empire at War, oder?

Aehm du hast vielleicht schon das Problem erwaehnt und erkannt, leider soviel Ich weiss kannst du nicht beide Versionen auf dem gleichen Rechner haben, soviel Ich in Errinnerung habe teilen beide Versionen Registry Eintraege. Daher empfehle Ich beides zu deinstallieren, regcleaner nach fehlerhaften EIntraegen suchen zu lassne (gerade Steam macht das gerne) und dann NUR die GOG version zu installieren.

Ich verwende W8.1 mit 20? mods und kein Problem. Abstuerze habe Ich eigentlich nur mit unvollendeten Mods :D

Bei der installation von mods darauf achten, das sich KEINE Daten davon ins root/data Verzeichniss von FOC eintraegt, IMMER nur ins mod Verzeichnisss (Einzeige Ausnahme leider RAW, aber da kann man ja einfach eine Kopie von FOC erstellen und dann umbennen, also Verzeichniss)

Wenn du Win10 verwendest, nur um sicher zu sein: Directx9 und directplay installiert?

Was ab und zu auch hilft bei WIn10, das Spiel als Admin auszufuehren. (Generel gesagt)
Fuer mods verwende ich grundsaetzlich bat-dateien, finde Ich einfacher.

Ach so, deinstallieren: das hat ohne sowas wie regcleaner o.ae. noch nie richtig funktioniert :D (nicht persoenlich gemeint ;) )

Gruesse Goodaltgamer
Hi,

das mit dem Registry aufräumen hat funktioniert - danke dafür.

Grüße, Aphain
avatar
Aphain: Hi,

das mit dem Registry aufräumen hat funktioniert - danke dafür.

Grüße, Aphain
Hi,

Frage und dir wird geholfen ;)

Und Bitte schoen

Gruesse
Goodaltgamer