It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Fellow Apple users,

This game is nearly impossible to get running in OSX natively with all the bells and whistles enabled due to it's age. Though there are solutions around the net to get the game running via Wine / Winetricks / Crossover, they only allow software rendering.

As I've spent the past day and a half trying to find a viable solution to running this game with Hardware Acceleration / Direct3D enabled on my mid-2012 13" MacBook Pro (Intel HD 4000), I'd like to offer a confirmed working solution.

-OSX 10.9+ (Tested on 10.11.1 - El Capitan)
-VMWare Fusion (Tested with 8.0.2)
-WIndows 2000 SP4 (Tested with retail copy)
-GoG copy of Dark Forces 2 - Jedi Knight

-Make sure your hardware version is set to "7" - do not chose the option to upgrade your virtual machine if prompted! The latest versions of VMWare Fusion disable Direct3D / 3D Acceleration by default if the hardware version is changed, according to my research.


-Install Windows 2000 (Make sure HW Compatibility is set to 7 when prompted!)
-Install VMWare tools
-Make sure 3D Acceleration is enabled in Virtual Machine -> Settings -> Display
-Install the game using the GoG installer as usual - During installation, it will appear that the installer has frozen / is not working - Wait a few minutes. You will receive an error message - This is normal, and can be ignored. The game will install properly anyway.
-No additional configuration is required - Just make sure that "Enable 3D acceleration" is checked off in the display settings.

And thats it! No hacks required, no need to replace ddraw.dll... even the sound works flawlessly!

Hopefully this helps somebody else out there and saves the time and frustration. Huge kudos to the GoG team for making this possible!
Post edited November 17, 2015 by MikeyC245