It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

hello gogers...

is there a way to increase the framerate? it seems to be locked at 20-30 fps even with 3d accelation enabled...makes the whole game and aiming a bit wibbily wobby...

got the original cd version and i remember the game much more smoother in software mode (but maybe i m wrong...didnt play this version for a long time XD)

the sticky threats are just about the hd mods with better models i guess....just want to run the eyehurting original much smoother XD


p.s. damn was to there any way to mark this threat as a question afterwards?
Post edited May 25, 2015 by ZombieIX
Is this about Jedi Knight: Dark Forces II?

If so: Jedi Knight itself seems to run at an uncapped framerate (use FRAPS or a similar tool to check how it's running on your system), but certain parts of the game seem to run at fixed framerates (e.g. first-person weapon / hand animations) while others do something else again...

The camera movement is weird. If the game is running at 60fps, the camera seems to update at 30fps (every second frame). If the game is running at 120fps, the camera updates at 40fps (every third frame)...

Possible partial fix: capping the framerate at 47fps seems to make the camera update at 47fps - which feels a bit smoother than the 30fps camera movement when the game is running at 60fps.
Capping at multiples of 47 might work as well
Post edited May 26, 2015 by DreadMoth
jeah thats it...while the weapon animation is smooth (like around 60 fps) the mouselook seems to be around 30 fps (odd and a bit annoying)

uhm how can i cap the framerate to 47? ^^
Here's one way of doing it...

Good luck.
ZombieIX: uhm how can i cap the framerate to 47? ^^
I used RivaTuner Statistics Server.

Once downloaded and installed, run RivaTuner Statistics Server and click the big + button at the bottom left.
Browse to "C:\GOG Games\Star Wars Jedi Knight - Dark Forces 2\" (or wherever you have Jedi Knight installed), click on the "JK.exe" and click "Open" to create a profile for the game.
I used these settings - you can turn off the "Show On-Screen Display" option if you don't want the framerate counter.
Once you've configured the settings you want, launch Jedi Knight - hopefully everything will work correctly.

EDIT: updated settings image link (minus ate my pictures :-/ )
Post edited December 29, 2015 by DreadMoth
yay ...thx alot for your help guys