It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
avatar
Hilmibear: So I basically combined all of the above troubleshooting tips, and now it works fine!

I switched to compatibilty mode for XP SP2, run as admin, and I installed the most recent DX Runtime from the Microsoft website.

Don't forget to actually restart the system after, cause it didn't work for me without it!
avatar
Body89: I can confirm that installing DirectX manually fixed the stuttering for me (Win 10). Compatibility mode is not needed anymore.

Installer: https://www.microsoft.com/en-us/download/confirmation.aspx?id=8109

After unpacking, you have to start installation by executing 'DXSETUP.exe'. Don't forget to restart afterwards.

Hope it helps!
That did the trick for me as well, thank you !
For me, simply changing compatibility mode to windows 7 did the trick. It runs flawlessly. I tried applying the widescreen mod but it didn't work but 1600x1200 works fine and it is in wide screen on my PC.
I don't know about anyone else, but this seems to have been fixed now? I had the stuttering in some parts of the game, but it didn't really affect my gameplay.
avatar
philyburkhill: I don't know about anyone else, but this seems to have been fixed now? I had the stuttering in some parts of the game, but it didn't really affect my gameplay.
Apparently restarting the computer is essential for this game to be smooth, at least for me. I had to discovered it two days after the install.
Sorry to "resurrect" but I ran into this when trying to play Bridge Commander on my laptop, and I wanted to add my commentary. Basically, the performance was very choppy for many things but smooth when just panning around the bridge. I thought that maybe it's just how this game is (and I didn't remember it from when I played it 15+ years ago)... but I looked on YouTube and definitely saw videos of smooth playback.

I fought with it for a while, but the solution for me was this, basically, just reboot. After rebooting, I noticed some alerts in Action Center from Windows Store, saying that it was installing some old Visual C++ runtime and also a DirectX runtime. Maybe that fixed something with this game? Anyway, it seems fine now.
Post edited December 14, 2021 by aaron44126
So I installed on a Windows 7 machine. Downloading and installing DirectX 11 helped, but what really madei t run smoothly for me was getting the application DXWnd. There's even a profile for Star Trek Bridge Commander included in DXWnd. Newer software doesn't use DirectX like older software, so older software on newer machines (and hardware) can get confused. DXWnd helps correct for this.
avatar
philyburkhill: I don't know about anyone else, but this seems to have been fixed now? I had the stuttering in some parts of the game, but it didn't really affect my gameplay.
avatar
Gudadantza: Apparently restarting the computer is essential for this game to be smooth, at least for me. I had to discovered it two days after the install.
I can confirm rebooting your computer fixes the problem. This is similar to the animation stuttering you will see in Neverwinter Nights 2. Same fix.
Bad coding is the problem, shame on those guys. If your computer's clock is running for a very long time (a week+) then the internal counter gets very high and the math in the game starts to break down. Just shoddy programming.
I've found that if using NVidia with a newer GPU and playing an old game I sometimes get stuttering unless I go to NVidia 3D settings for that game and enable low latency mode. For some reason older games can periodically stutter without that setting enabled.

That fixed this game for me.