It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Here is what GOG support advised me (and it's an easy solution too) if you want another way to switch languages : switching localization file manually.
I'll show the french example :) (almost copy-past from their answer, and it's working perfectly well)

1) Navigate to your game's French localisation directory. By default, this should be:
C:\GOG Games\S.T.A.L.K.E.R. Shadow of Chernobyl\Localization\Fr

2) Now locate the "gamedata.db9" file, and copy it directly into the game's main directory overwriting the file currently present:
C:\GOG Games\S.T.A.L.K.E.R. Shadow of Chernobyl\

3) If you ever want to go back to English, make sure to back up the original gamedata.db9 file before the manipulation.
Post edited December 08, 2014 by Splatsch
avatar
Calzifer: There is a possible workaround for Windows.

First start settings.exe and change the language back to english if another language is currently selected.

Then open the registry (win + r -> regedit) and navigate to the game entry.

Shadow of Chernobyl: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\GOG.com\Games\1207660573
Call of Pripyat: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\GOG.com\Games\1207660583
Clear Sky: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\GOG.com\Games\1207660603

Note: for 32bit Windows just skip the Wow6432Node part.

Search the value for PATH. If it's not ending with a backslash add one.
e.g. "C:\GOG Games\S.T.A.L.K.E.R. Shadow of Chernobyl" must be changed to "C:\GOG Games\S.T.A.L.K.E.R. Shadow of Chernobyl\"

Now you can change the language with settings.exe as intended.
I made what you said, and the backslash was effectively missing. It is working perfectly now with your instructions, and I can switch the language I want with settings.exe. Thank you for the help !

Warning : the folder "C:\GOG Games\S.T.A.L.K.E.R. Shadow of Chernobyl\Localization" must be just like if the game was just installed (when I first tried your solution, I had backed up my english "gamedata.db9" file into the folder "C:\GOG Games\S.T.A.L.K.E.R. Shadow of Chernobyl\Localization\En", and it denied the solution to work).
Post edited December 08, 2014 by Splatsch
avatar
Splatsch: Here is what GOG support advised me (and it's an easy solution too) if you want another way to switch languages : switching localization file manually.
I'll show the french example :) (almost copy-past from their answer, and it's working perfectly well)

1) Navigate to your game's French localisation directory. By default, this should be:
C:\GOG Games\S.T.A.L.K.E.R. Shadow of Chernobyl\Localization\Fr

2) Now locate the "gamedata.db9" file, and copy it directly into the game's main directory overwriting the file currently present:
C:\GOG Games\S.T.A.L.K.E.R. Shadow of Chernobyl\

3) If you ever want to go back to English, make sure to back up the original gamedata.db9 file before the manipulation.
Thanks! It worked for me!
i have the russian audio version installed, now i want to install english subtitles.

how?

the localization folder is so i can change the subtitles, not the audio, right?

if so, i cannot find a localization folder in my root directory.