It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

In my case the game defaults to a stretched 4:3 resolution and to be honest it doesnt look too bad but would like to play it in 4:3 with black borders on the left and right, if only to compare and see if it feels a bit better. Is this possible?
I forget if this is the exact process but if you've an Nvidia card then:

1) Go to GeForce Experience

2) On the page that appears go to the left hand menu and go down and click on the "Display" dropdown and pick "Adjust Desktop size and position"

3) In the page that appears under the 2'nd option the first subsection is "Select Scaling Method"

4) Under that title pick "no scaling"

You may also have to select in the two options right below that
"Perform Scaling on GPU"


Tick the box for "override the scaling mode set by games and programs"

Once done click the icon in the bottom right to save the settings. Your game should now play in the letter-box style without any scale change to fit the screen.
Thanks, I think that does look/feel better for this title in my opinion. I'll just note that it's Nvidia control panel as opposed to Geforece Experience :)