It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Yeah windows 7 does not contain any of the compat fixes that the pcgmaing wiki file has, at all.

I suggest you guys just for now, try switching your color modes to 16-bit when you want to play and then going back to 32-bit when you are done.

maybe that might fix the suttering for now give it a shot and get back to me.
I have a potential solution to running windowed, but it involves a third party app...

Will have a result later today.
All right.

So here is what I think is going on.

Windows 8 and up, do not use DirectX's 16bit display mode anymore, from what I have read and seen, they cant so those compatibility fixes from pcgamingwiki will only work on a win 8 system and up to maybe windows 10. (still not 100 percent sure on this so take any of my words with grains of salt the size of peter molyneux's ego..) they also use compatibility shims and fixes that ARE NOT in windows 7 at all, so those of you having the problem on windows 7 installing them will do jack and shit, and jack left town....

SO how do we fix this? well as I previously stated, since Windows 7 still has the ability to go into 16 bit color mode you can try doing that and see how that works, there is a program that I am messing around with, that will do it automatically and then return it to your original config after you are done ruining tiny computer lives, so after I do a couple of more tests with this method, I will post instructions and downloads on how to run it.

but could the guys having issues with stuttering try setting their desktops to 16 bit color mode to see if it fixes that problem on windows 7? it would aid me greatly.

I am also testing a couple of other fix ideas I have but I cannot report any progress until this is done.

Remember I am not a programmer, just a troubleshooter so I cannot make patches and stuff.

I wait your results warmly and with slight moments of arousal...

I'm sorry to destroy your precious recent efforts but I tested the game with 16-bit colours and there was no improvement :(

Here is what I got from the support. I'll do it "later" after sleeping and working.


Currently our German support is overwhelmed with work. If you don't mind I will reply using English language.

Please try following these troubleshooting steps:
1) Please make sure that you use "Run as Administrator" to install and to start the game (right-click on the shortcut or setup file and select "Run as Administrator"). If you are using Galaxy, then make sure to run Galaxy as Administrator.

2) Please reinstall the game AND add it to your anti-virus/firewall software's exception/trusted list. Simply disabling firewall or AV software could not be enough, since some of these software are running still in background or in services list. If you are using Galaxy, then please add Galaxy as well.

3) Reinstall the June 2010 DirectX runtime package. You can find the archive file containing the 2010 package installation files here:

You will have to extract the files into some folder, then open that folder and launch the DXSETUP.exe file in order to proceed with the installation.

After that please download and install DirectX Web Installer:

Please have in mind that this will only add DirectX 9.0c to available pool of DirectX libraries, and it will not overwrite your other versions. Some games are not able to utilize newer DirectX libraries, and they require DirectX 9.0c.

4) Please update your graphics device drivers:

5) Please try to installing compatibility mod from PC Gaming Wiki:

Please copy archive's content to game installation folder\Apps (default: C:\GOG Games\SimCity 3000 Unlimited\Apps) and run Install.bat.

6) If above didn't help, then please go to game installation folder (default: C:\GOG Games\SimCity 3000 Unlimited\). once in there find "Launch SimCity 3000 Unlimited" shortcut right-click on it, and select Properties. In Properties window, go to Shortcut tab and in target field add:
-w -r:800x600

If you installed the game to default location, then it should look something like this:
"C:\GOG Games\SimCity 3000 Unlimited\Apps\SC3U.exe" -w -r:800x600

Press Ok to accept changes. After that run the game using modified shortcut. The game should start in windowed mode. Once in Main Menu, go to Preferences -> Screen Resolution -> and here select 1280x1024 resolution. Accept changes to restart the game, and game should start in higher resolution.

Dr Cat
Customer Support Representative
Post edited July 21, 2016 by Lesser
Lesser: I'm sorry to destroy your precious recent efforts but I tested the game with 16-bit colours and there was no improvement :(
shit fuck damn boobs.

must be a gpu related issue.
if its gpu related its become 982304u3284230847237428347238742834723429348294 to the power of tinye harder to solve, the u means its serious.

Post edited July 21, 2016 by Lord_Kane
Alright I believe I found a solution on WINDOWS 7 :

The only way the ui doesn't stutter is to run the game in windowed mode.

As previously instructed, just add "-w -r:800x600" in the shortcut target.

BUT for the game to start in windowed mode, you have to switch to 16 bits colors BEFORE you start the game ! If you let Windows do this automaticaly at the start of the game, it won't work.

And halleluja, now the ui runs smoothly in every resolution.

You can even add HD res by using an hex editor - easy to find on the web. Just stay in windowed mode, and that's it.