It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Having an annoying problem. I cannot get the game to work in fullscreen. When I try, a frozen frame of the intro video stays onscreen while I can hear the background music for the main menu. I even managed to accidentally open a city by clicking randomly (apparently I doubleclicked a default city). Disabling the intro video does not help, I just get a black screen while the music plays. If I alt tab away and then back to it, I can see the menu, but can't click on anything. My mouse cursor is also trapped like it's in a window.

I added some shortcut parameters to make it open in windowed mode and that gets me past the above issue, but I don't want to play in Window mode. I also cannot make it use the correct screen resolution (1080p). It won't accept anything above 1280 x 1024.

My shortcut target currently looks like this: "C:\GOG Games\SimCity 3000 Unlimited\Apps\SC3U.exe" -w -intro:off -r1280x1024x32
I tried the "-CustomResolution:enabled" switch but it doesn't do anything.
Windows "Game Mode" is disabled
I've tried several different compatibility options, like disabling "full screen optimizations" and "run in administrator mode," run as Windows 98, Windows 7, Windows XP. None of this helps anything.

GPU is a Radeon 5700XT on Windows 10 1909, latest drivers
No posts in this topic were marked as the solution yet. If you can help, add your reply
Not sure if this will work with SimCity but it has worked on other old games.
Set the Display Size you want on Display Settings.
Right Click the icon for SimCity and hit trouble shooting.
One of the choices (first or second I forget which) involves display size.
Hit Test. If it woks, Hit continue, and the computer will remember what screen size to use when you start the game.
Hope it works.
Edit Sp
Post edited February 23, 2020 by macAilpin
Or use my guide to get the game running using DxWnd.
DxWnd has a built-in framerate limiter that will mostly fix the main problem. And if you want you can follow the extra steps to make the UI/fonts look bigger on the screen.