It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Anyone not understanding this? It was the same way as in the original and kinda annoyed its not working still I have auto-budget uncheck and still don't see my year income am I missing something?
this is for Simcity 3000 Unlimited!
Post edited July 09, 2019 by goro3d
This appears to be a bug with SimCity 3000 Unlimited on Gog. Whether you check or uncheck Auto Budget, the budget screen will not appear on Jan 1 as it should. I found that if you go to city options, check it then uncheck it, then click OK, then it will work as long as you don't quit or restart the program. It still needs fixing though.