It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
avatar
revanbh: I'm not sure why this isn't already here, but a simple addition of the following line: DirectDraw=0, to your Alpha Centauri.ini file will enable you to play the game in your native resolution, no matter what resolution you are using.

It should look something like this:

Example from my own Alpha Centauri.ini file

[PREFERENCES]
ForceOldVoxelAlgorithm=1
[Alpha Centauri]

ds3d=1
DirectDraw=0
eax=1

FastUnitAnim=0
SmoothUnitAnim=0
MainFontSize=16
InterludeFontSize=16
DisableOpeningMovie=0
Prefs Format=12
Difficulty=2
Map Type=2
Top Menu=3
Faction=1
Preferences=10111011111000011101110110110110
More Preferences=1110100111000101101000
Semaphore=00000000
Announce=111100001110101001
Rules=1101000101110
Customize=2
Custom World=2, 1, 1, 1, 1, 1, 1,
Time Controls=1
Latest Save=F:\Revan\My Games\GOG Games\Sid Meier's Alpha Centauri\saves\Deirdre of the Gaians, 2187
Latest Scenario=
WindowsFileBox=0

I've found this on another old thread and all credit goes to the user zicoos. I'm just posting it here to be more visible.
This is absolutely amazing, you have some black bars underneath the interface though but it's not that problematic. Thank you very much!
avatar
sparkyhodgo: Replace the "video mode=###" line with "directdraw=0"

That will use your desktop's native resolution. I have no idea why this isn't a documented feature.
This fixed an issue for me where my mouse cursor appeared surrounded by an ugly black box, thank you. (Win7 64)
So glad to see this here and as a stickied thread. First thing I saw when popping into this forum to see if anyone had a solution, and here it was :)
So I just installed SMAC on my Surface Pro 3. Was impossible to play before this thread, as I only got a postage stamp to play on. Now I get the whole screen. If you are playing on a high-DPI screen, you can update the fonts in the .ini to 32 to make a lot more of the interface readable.

Doesn't scale the whole interface, sadly, but does make parts of it more legible.
avatar
revanbh: I'm not sure why this isn't already here, but a simple addition of the following line: DirectDraw=0, to your Alpha Centauri.ini file will enable you to play the game in your native resolution, no matter what resolution you are using.
Thank you so, so much.
I've been playing SMAC for ages on my 1280x1024 screen in the original resolution.

Bought a laptop with 1920x1080 and just wanted to get rid of the black borders, and now I see this.
SMAC is way easier to play when zoomed out a bit, the overview is way better.

And it looks so damn sleek. Reactions of people seeing me play it have gone from "What is that pile of garbage?" to "That looks interesting, what is it?"


Edit: I'd attach a screenshot, but that doesn't seem to work. Spam countermeasure?
Post edited December 22, 2014 by Snorpp
avatar
Snorpp: Thank you so, so much.
I've been playing SMAC for ages on my 1280x1024 screen in the original resolution.

Bought a laptop with 1920x1080 and just wanted to get rid of the black borders, and now I see this.
SMAC is way easier to play when zoomed out a bit, the overview is way better.

And it looks so damn sleek. Reactions of people seeing me play it have gone from "What is that pile of garbage?" to "That looks interesting, what is it?"


Edit: I'd attach a screenshot, but that doesn't seem to work. Spam countermeasure?
Happy to help. ;)

People often underestimate SMAC in terms of graphics, but I find it aesthetically superior to any other game under Sid Meier moniker. Higher resolutions bring this out even more. This game is my unsurpassed 4X title.
For anyone's future reference, I have an HP Notebook running windows 10 with 1366X768 resolution. The fix that worked for me was simply disabling the startup movie by having "DisableOpeningMovie=1".
Post edited January 16, 2016 by phermann