It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
I've been trying for about a year on and off to get this game to work, and thanks to this forum I finally fixed it. I thought I would make a post explaining my exact steps so hopefully others can quickly find this fix.

My computer is running Windows 7 64-bit Japanese Pro. I was living in Japan when I bought Windows 7, and since moving back I have worked as a part-time translator. As such, I have Japanese as my default input language and IME as my default keyboard for switching between EN and JP on the fly.

Reading another thread, I saw a Korean gamer (dailyblue) fixed his crash issue by changing the IME setting to normal English keyboard. And it worked for me too!

-Go to Control Panel
-Select Region and Language
-Keyboard and Language tab
-Select Change keyboards
-Set the default input language to English (United States) - US
-Under Installed services, have the English (United States) at the top of the list, using US under Keyboard
-**If you have the Language Bar active, double-check that it is set to EN when you are in Windows Explorer and about to launch the game

I also run in Compatibility mode for Windows XP (Service Pack 2) and have it set to run as administrator. And I use the INI fix, my Alpha Centauri.ini looks like this:

[Alpha Centauri]
Video Mode=1024
ForceOldVoxelAlgorithm=1
DirectDraw=0
ds3d=0
eax=0
FastUnitAnim=0
SmoothUnitAnim=0
MainFontSize=16
InterludeFontSize=16
[PREFERENCES]
ForceOldVoxelAlgorithm=1

Hopefully anyone having trouble can benefit from my experience! Happy gaming!
it working :) thank you very much.
avatar
tehmarken: I've been trying for about a year on and off to get this game to work, and thanks to this forum I finally fixed it. I thought I would make a post explaining my exact steps so hopefully others can quickly find this fix.

My computer is running Windows 7 64-bit Japanese Pro. I was living in Japan when I bought Windows 7, and since moving back I have worked as a part-time translator. As such, I have Japanese as my default input language and IME as my default keyboard for switching between EN and JP on the fly.

Reading another thread, I saw a Korean gamer (dailyblue) fixed his crash issue by changing the IME setting to normal English keyboard. And it worked for me too!

-Go to Control Panel
-Select Region and Language
-Keyboard and Language tab
-Select Change keyboards
-Set the default input language to English (United States) - US
-Under Installed services, have the English (United States) at the top of the list, using US under Keyboard
-**If you have the Language Bar active, double-check that it is set to EN when you are in Windows Explorer and about to launch the game

I also run in Compatibility mode for Windows XP (Service Pack 2) and have it set to run as administrator. And I use the INI fix, my Alpha Centauri.ini looks like this:

[Alpha Centauri]
Video Mode=1024
ForceOldVoxelAlgorithm=1
DirectDraw=0
ds3d=0
eax=0
FastUnitAnim=0
SmoothUnitAnim=0
MainFontSize=16
InterludeFontSize=16
[PREFERENCES]
ForceOldVoxelAlgorithm=1

Hopefully anyone having trouble can benefit from my experience! Happy gaming!
Very nice! This is the answer. Defualt EN keyboard solves all the problem! This post got to be sticky.
Thank you so much for figuring this out!
Wow it finally worked! Thank you so much.
tehmarken, you are a god send!! I had honestly given up on getting this to work after having tried everything, even AppLocale. Thank you! This should be a sticky for all those with an Asian language OS
BRILLIANT!!

I couldn't for the life of me work out why this game was consistently crashing across all my systems. I tried everything that I could, often several times. It never occurred to me that the problem could be caused by my language settings (Korean IME). Thank you!!
OH. MY. IT WORKED.

I live in Japan and have been trying to get the game to work on and off for the past 7 years, but no fix or solution or compatibility setting did anything, not even reinstalling windows!

I'm running Win7 x64 (English edition) presently, but in the past I also had XP and same crash issue.
So all these years, it's been having Japanese as default language set!

I'm so happy right now. Thank you very very much.

This needs to be posted somewhere visible because I'm sure there are other people having the same issue out there.
I am SO glad I checked older forum posts..
You deserve to win the internets tehmarken.

You won't believe how many .ini settings and compatibility combinations I've used.
Then tried with the SDK of DXJune2010 installed (had to try them all over again).
Then with resolution settings turned down.
Then with AppLocale (I'm Dutch, my keyboard is US International [but set to Japanese IME], my language is English UK and System Locale is Japan xD).
Finally added exceptions to my firewall.

Simply having Engish US as the default language for input fixed this >.>

In fact, I undid the compatibility settings (I run everything as Admin, so that stays), reverted the .ini file to the backup I had made, undid my resolution changes, removed the firewall exceptions and let it run in System Locale; works.
Post edited April 16, 2014 by tiaxanderson
Unfortunately this does not help me at all. The game still crashes. I wonder if it's because I have an ATI card? My drivers are not new. Sigh
avatar
tehmarken: I've been trying for about a year on and off to get this game to work, and thanks to this forum I finally fixed it. I thought I would make a post explaining my exact steps so hopefully others can quickly find this fix.

My computer is running Windows 7 64-bit Japanese Pro. I was living in Japan when I bought Windows 7, and since moving back I have worked as a part-time translator. As such, I have Japanese as my default input language and IME as my default keyboard for switching between EN and JP on the fly.

Reading another thread, I saw a Korean gamer (dailyblue) fixed his crash issue by changing the IME setting to normal English keyboard. And it worked for me too!

-Go to Control Panel
-Select Region and Language
-Keyboard and Language tab
-Select Change keyboards
-Set the default input language to English (United States) - US
-Under Installed services, have the English (United States) at the top of the list, using US under Keyboard
-**If you have the Language Bar active, double-check that it is set to EN when you are in Windows Explorer and about to launch the game

I also run in Compatibility mode for Windows XP (Service Pack 2) and have it set to run as administrator. And I use the INI fix, my Alpha Centauri.ini looks like this:

[Alpha Centauri]
Video Mode=1024
ForceOldVoxelAlgorithm=1
DirectDraw=0
ds3d=0
eax=0
FastUnitAnim=0
SmoothUnitAnim=0
MainFontSize=16
InterludeFontSize=16
[PREFERENCES]
ForceOldVoxelAlgorithm=1

Hopefully anyone having trouble can benefit from my experience! Happy gaming!
thanks now it works!
from Korea :-)
avatar
tehmarken: I've been trying for about a year on and off to get this game to work, and thanks to this forum I finally fixed it. I thought I would make a post explaining my exact steps so hopefully others can quickly find this fix.

My computer is running Windows 7 64-bit Japanese Pro. I was living in Japan when I bought Windows 7, and since moving back I have worked as a part-time translator. As such, I have Japanese as my default input language and IME as my default keyboard for switching between EN and JP on the fly.

Reading another thread, I saw a Korean gamer (dailyblue) fixed his crash issue by changing the IME setting to normal English keyboard. And it worked for me too!

-Go to Control Panel
-Select Region and Language
-Keyboard and Language tab
-Select Change keyboards
-Set the default input language to English (United States) - US
-Under Installed services, have the English (United States) at the top of the list, using US under Keyboard
-**If you have the Language Bar active, double-check that it is set to EN when you are in Windows Explorer and about to launch the game

I also run in Compatibility mode for Windows XP (Service Pack 2) and have it set to run as administrator. And I use the INI fix, my Alpha Centauri.ini looks like this:

[Alpha Centauri]
Video Mode=1024
ForceOldVoxelAlgorithm=1
DirectDraw=0
ds3d=0
eax=0
FastUnitAnim=0
SmoothUnitAnim=0
MainFontSize=16
InterludeFontSize=16
[PREFERENCES]
ForceOldVoxelAlgorithm=1

Hopefully anyone having trouble can benefit from my experience! Happy gaming!
You're also probably better off changing your ini to this

[Alpha Centauri]
ForceOldVoxelAlgorithm=1
DirectDraw=0
ds3d=0
eax=0
FastUnitAnim=0
SmoothUnitAnim=0
MainFontSize=16
InterludeFontSize=16

You had duplicates of ForceOldVoxelAlgorithm, and you shouldnt have Video Mode if you have DirectDraw=0
I am in the same boat. I live in Japan and work as a professional translator, and my gaming PC is my work PC. Changing the default language would likely not cause too many problems for me, but my livelihood depends 100% on my computer so I can't risk fooling around with language settings.

Fortunately there is one other way, though you have to play it in a window:

http://blog.goo.ne.jp/mexe/e/b149d1c5b4b79874666c83e461113739

It's in Japanese, but the gist is:

1) Place the following two lines in GOG Games¥Sid Meier's Alpha Centauri¥Alpha Centauri.Ini:
(directly under [Alpha Centauri])
Video Mode=1024
KeepRes=1

2) Download the DirectX window tool and place it in a convenient folder of your choosing:
http://www.geocities.jp/menopem/
(DirectXウィンドウ化ツール1.88) is the name of the tool in Japanese

3) Start D3DWindower.exe in the folder you created in step (2)
4) Click the + button, then specify either terran.exe (SMAC) or terranx.exe (SMAC:AC) from the GOG\AC folder
(I recommend doing steps 4-9 for both exe files, so you can choose whether to run the game with the expansion or not)
5) Right click the file you added in step (4), the click the first option 設定
6) On the first tab 共通 set the following:
First box 幅を固定: 1024
Second box 高さを固定: 768
(these set the resolution of the window you will play in)
7) On the same tab 共通 click the box on the bottom right 開く and specify the D3dHook.dll file in the folder you created in step (2)
8) Click the third tab 最前面管理 and check the following (from top to bottom):
First box 最前面管理
Fourth box ウィンドウの座標を固定する
9) Click OK

This brings you back to the main screen of the tool.

From now on, to launch the game:
1) Launch the directx tool
2) Double-click "terran" or "terranx" to launch SMAC or SMAC:AC

---

Downsides to this method:
- You need to play in a window
(not really a downside on modern monitors, as SMAC is a 2d game and looks horrible scaled up to modern resolutions)
- You cannot scroll maps by bringing the mouse cursor to the edge of the screen
(there are alternate ways to scroll maps, so this doesn't prevent you from playing the game)
- FMV audio is hit or miss


Hope this helps!!