It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
avatar
Jyuki: After playing around a little bit, I've come with a fix to play Shogo on Windows 10

1. Install the game

2. Download the latest dgVoodoo 2 ( dege.freeweb.hu/dgVoodoo2/dgVoodoo2.html )

3. Unzip the 4 .dll from "dgVoodoo2_62_3.zip/MS/x86" folder into Shogo root folder "C:\Program Files (x86)\GOG Galaxy\Games\Shogo - Mobile Armor Division)"

4. Unzip dgVoodooCpl.exe & dgVoodoo.conf into Shogo root folder.

5. Launch dgVoodooCpl.exe, uncheck "dgVoodoo Watermark" from the DirectX tab & Apply.

6. Activate DirectPlay In Windows 10 ( softlay.net/how-to/enable-directplay-windows-10.html )

7. Reboot the PC if prompted.

8. In Shogo's launcher, go to Display and select dgVoodoo API with your desired resolution.

9. Enjoy.
YOU'RE MY ABSOLUTE HERO! I just bought a dozen games and this is the one I'll be playing. Held back getting it for so long because of compatibility but now I can beat it for like the fifth time. Seriously, thank you.
avatar
ploider: I found that disabling one of the "HID-compliant vendor-defined devices" in Device Manager (may take some experimentation to find which one), under Human Interface Devices, resolved the black box/not launching issue, both in Shogo and other Lithtech games.
avatar
Cochese25: I had to disable 2 items, but this worked for me as well. (after doing all of the above stuff, so I don't know if it was the final piece of the puzzle or if all you had to do was disable HID components).

Widescreen fix lets me use my entire 4500x3000 display!
What the hell on earth.....disabling the f-ing HID worked to me!!! Thanks for the hint!!!!!
I disabled every HID-compliant vendor-defined device and still no dice. I don't think I missed any of the steps mentioned here. Still getting the instant close after the little black box. Any other suggestions?
avatar
djkurzman: I disabled every HID-compliant vendor-defined device and still no dice. I don't think I missed any of the steps mentioned here. Still getting the instant close after the little black box. Any other suggestions?
Ok, so i brought shogo and got it working, I had the same black box issue. My solution is as follows:

1. Go to this comment ( https://github.com/elishacloud/dxwrapper/issues/54#issuecomment-537794922 ) and download the dinput.dll and put it in the main directory. This will allow the game to launch and stop the black box crash issue.

2. Download and run this exe ( https://www.moddb.com/downloads/shogo-fix )
your browser might flag it as unsafe but i had no issues running it with defender, it's a false positive anyway the file is safe.

3. Download the Shogo_21-9.rar file from Attachments on this page (https://www.wsgf.org/phpBB3/viewtopic.php?f=95&t=28031 ) and ONLY extract the D3DIM.DLL file to your main directory.

4. Run Shogo.exe and choose Display, it should be set on dgVoodoo and now you can also set the resolution to over 1080p without it going back to 640x480.

5. Choose Customize from the launcher and make sure the widescreen patch is under "Rez files to load" and "Always load these rez files" is ticked

6. Go to Advanced and make sure the only boxes ticked are "Enable Poly Gap Fixing" and "Enable Triple Buffering"

7. Launch the game and (hopefully) enjoy!
Post edited June 26, 2021 by DetsEightyOne
avatar
djkurzman: I disabled every HID-compliant vendor-defined device and still no dice. I don't think I missed any of the steps mentioned here. Still getting the instant close after the little black box. Any other suggestions?
avatar
DetsEightyOne: Ok, so i brought shogo and got it working, I had the same black box issue. My solution is as follows:

1. Go to this comment ( https://github.com/elishacloud/dxwrapper/issues/54#issuecomment-537794922 ) and download the dinput.dll and put it in the main directory. This will allow the game to launch and stop the black box crash issue.

2. Download and run this exe ( https://www.moddb.com/downloads/shogo-fix )
your browser might flag it as unsafe but i had no issues running it with defender, it's a false positive anyway the file is safe.

3. Download the Shogo_21-9.rar file from Attachments on this page (https://www.wsgf.org/phpBB3/viewtopic.php?f=95&t=28031 ) and ONLY extract the D3DIM.DLL file to your main directory.

4. Run Shogo.exe and choose Display, it should be set on dgVoodoo and now you can also set the resolution to over 1080p without it going back to 640x480.

5. Choose Customize from the launcher and make sure the widescreen patch is under "Rez files to load" and "Always load these rez files" is ticked

6. Go to Advanced and make sure the only boxes ticked are "Enable Poly Gap Fixing" and "Enable Triple Buffering"

7. Launch the game and (hopefully) enjoy!
Just wanted to bump this. Step one with the dll was enough to make the game run for me after getting dgVoodoo.

Thank you so much!