It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I can't seem to get it to load right at all under Ubuntu. Any suggestions?
What have you done so far to try and get it to work?
be sure to check the autoexec part of the gog provided configfile for dosbox.
(remove the exit line and the cls line)
OK, so far I figured out a little bit here. I copied all the files to my DOSBox mounted folder renamed to SSTEEL now. I put in 'imgmount d /ssteel/ssteel.gog -t iso -fs iso'. The default conf file has ssteel.inst listen instead of *.gog, but the .inst file never mounted for me. When I mount the .gog, it appears to mount it now. It comes up 'MSCDEX installed. Drive D is mounted as [DOSbox folder]/ssteel/ssteel.gog.' I run ssteel.exe and it looks like it's loading fine but then it stops and says 'world1.pol' not found. That's as far I have gotten.
open the .inst file and look for the casing of the refered .gog file in there.
always mount the .inst file
Well, I figured out how to mount inst file properly, but I still have the same problem. 'world1.pol not found'
right. did you use the configfile the GOG team uses ?
(and from the right directory ?)
Yes. I get a black window with a blinking cursor. Nothing appears to load.
I think you are on 64 bit linux right ?
Do this for DOSBox 0.72 (CVS doesn't seem to need it)
go to the directory of shatered steel.
open dosbox.conf
core=auto to core=normal
change the
imgmount d ".\SSTEEL.inst" -t iso -fs iso
imgmount d "SSTEEL.inst" -t iso -fs iso
save the file
dosbox -conf dosbox.conf
if it crashes try changing
cycles = 20000
(or higher or lower if the game is too slow)
Yep, I still don't get it. I tried messing around with the conf settings like you stated and I still get nothing. In the dosbox console I get the same old 'world1.pol not found'. I guess I'm going to have to sit on this one for a while.
OK, I finally got it fixed. In the conf file I figured out I had to mount the game's directory as the DOS directory then change the image file name to the shortened DOS name. So basically my conf now looks like this
mount c dos/ssteel
imgmount d SSTEEL~1.ins -t iso -fs iso
I also used the same method to get Screamer to work for me. I guess this would be helpful to all the Linux user out there if they need it.
Post edited April 22, 2009 by NssOne

did it manually to test but works like a charm :)

Thanks NssOne !