It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

So it move with the mouse by default (jesus christ why) so I went into the settings and tied movement to the keyboard, but every time I move the mouse I still go forward/backward. How do I disable that?
press "U"

Can also run setup.exe with dosbox and set your key bindings.