It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
avatar
Wishmaster777: Since both games use the same engine, this instruction works for both games .

Find the installation folder. Enter Scripts sub-folder. Find PersistentSymbols file. Open it.
Once the notepad file has been launched use the search function to locate these lines:
persistent extern user FLOAT plr_fFOV=(FLOAT)xx;

Change its default value into:
persistent extern user FLOAT plr_fFOV=(FLOAT)105; for 16:9 screen resoultion.
persistent extern user FLOAT plr_fFOV=(FLOAT)100; for 16:10 screen resolution.

Find these next:
persistent extern INDEX sam_iScreenSizeI=(INDEX)xxxx;
persistent extern INDEX sam_iScreenSizeJ=(INDEX)xxxx;

Change its value for desired screen resolution. Upper value is width, lower value is height:
persistent extern INDEX sam_iScreenSizeI=(INDEX)1920;
persistent extern INDEX sam_iScreenSizeJ=(INDEX)1080;

Enjoy the game with a modern resolution standard.
so, dont enable the widescreen option at all.
just edit the screensize and fov parameters in the persistentsymbols file.
now 4K works just fine.
For those looking for widescreen support and fixes for modern systems, take a look at this: https://www.gog.com/forum/serious_sam_series/update_for_serious_sam_tfe_and_tse

I may be being redundant with this topic I opened, but I just wanted to share this information, which may be old information for many old-school SS players. =)