It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
high rated
Since both games use the same engine, this instruction works for both games .

Find the installation folder. Enter Scripts sub-folder. Find PersistentSymbols file. Open it.
Once the notepad file has been launched use the search function to locate these lines:
persistent extern user FLOAT plr_fFOV=(FLOAT)xx;

Change its default value into:
persistent extern user FLOAT plr_fFOV=(FLOAT)105; for 16:9 screen resoultion.
persistent extern user FLOAT plr_fFOV=(FLOAT)100; for 16:10 screen resolution.

Find these next:
persistent extern INDEX sam_iScreenSizeI=(INDEX)xxxx;
persistent extern INDEX sam_iScreenSizeJ=(INDEX)xxxx;

Change its value for desired screen resolution. Upper value is width, lower value is height:
persistent extern INDEX sam_iScreenSizeI=(INDEX)1920;
persistent extern INDEX sam_iScreenSizeJ=(INDEX)1080;

Enjoy the game with a modern resolution standard.
Post edited January 10, 2021 by Wishmaster777
Thanks, dude, works great! Hopefully we can make this post a sticky.
Post edited January 11, 2019 by leiget
This is great but sometimes when I run the game the fullscreen still shows my DE taskbar and start menu. Is there any settings that I should mess with to make it open proper all the time.
avatar
Wishmaster777: Since both games use the same engine, this instruction works for both games .

Find the installation folder. Enter Scripts sub-folder. Find PersistentSymbols file. Open it.
Once the notepad file has been launched use the search function to locate these lines:
persistent extern user FLOAT plr_fFOV=(FLOAT)xx;

Change its default value into:
persistent extern user FLOAT plr_fFOV=(FLOAT)105; for 16:9 screen resoultion.
persistent extern user FLOAT plr_fFOV=(FLOAT)100; for 16:10 screen resolution.

Find these next:
persistent extern INDEX sam_iScreenSizeI=(INDEX)xxxx;
persistent extern INDEX sam_iScreenSizeJ=(INDEX)xxx;

Change its value for desired screen resolution. Upper value is width, lower value is height:
persistent extern INDEX sam_iScreenSizeI=(INDEX)1920;
persistent extern INDEX sam_iScreenSizeJ=(INDEX)1080;

Enjoy the game with a modern resolution standard.
Worked like a charm, thanks so much!
avatar
Obi-Ravioli: Worked like a charm, thanks so much!
You are welcome. :-)
avatar
_RafiLinux_: This is great but sometimes when I run the game the fullscreen still shows my DE taskbar and start menu. Is there any settings that I should mess with to make it open proper all the time.
There is a widescreen option in game. Ensure it is disabled.

Since the topic is about tweaking the .ini file I'd like to add this line:

hud_bShowMessages=(INDEX)0;

It makes the Netrisca message icon stay in the top of the screen instead of displaying in the center.


If you play via wine, also use this one:

gap_iDepthBits=(INDEX)24;

It forces the game to draw the objects in correct order, otherwise you'd see through walls and other strange visual glitches.
Post edited March 21, 2020 by etb
i don't have any text in the persistentsymbols file (cause i can't launch the game i think), so could someone copy/paste it hehre please ? thanks
Widescreen works but is not perfect. There is still a problem with the position of the weapon on the screen. Anyone know how to fix it?
Attachments:
Post edited May 30, 2020 by hinsten
avatar
hinsten: Widescreen works but is not perfect. There is still a problem with the position of the weapon on the screen. Anyone know how to fix it?
You can use binaries from Steam version, they have several fixes including weapon fov and restored multiplayer.
TFE: https://drive.google.com/file/d/1t1o1RBV6W3xJDKTrYe8GtjlciK3q22Mx/view?usp=drivesdk
TSE: https://drive.google.com/file/d/1nOPoi8gs3UJCxXG0N7jZCq6-qfRtznl1/view?usp=drivesdk
Post edited August 25, 2020 by vlad_54rus
I'd also recommend the steamify patches.

moddb.com/games/serious-sam-the-first-encounter/downloads/serious-sam-tfe-patch-steamify-no-steam-version
moddb.com/games/serious-sam-the-first-encounter/downloads/serious-sam-tse-steamify-patch-no-steam-version
What's the recommended fix now? Steamify, the binaries, .ini edits? All of the above?
avatar
soullos: What's the recommended fix now? Steamify, the binaries, .ini edits? All of the above?
Either Steamify or Binaries (latter are newer).
avatar
soullos: What's the recommended fix now? Steamify, the binaries, .ini edits? All of the above?
avatar
vlad_54rus: Either Steamify or Binaries (latter are newer).
Awesome, I'll use the binaries then since they're more up to date. :D
avatar
Wishmaster777: Since both games use the same engine, this instruction works for both games .

Find the installation folder. Enter Scripts sub-folder. Find PersistentSymbols file. Open it.
Once the notepad file has been launched use the search function to locate these lines:
persistent extern user FLOAT plr_fFOV=(FLOAT)xx;

Change its default value into:
persistent extern user FLOAT plr_fFOV=(FLOAT)105; for 16:9 screen resoultion.
persistent extern user FLOAT plr_fFOV=(FLOAT)100; for 16:10 screen resolution.

Find these next:
persistent extern INDEX sam_iScreenSizeI=(INDEX)xxxx;
persistent extern INDEX sam_iScreenSizeJ=(INDEX)xxx;

Change its value for desired screen resolution. Upper value is width, lower value is height:
persistent extern INDEX sam_iScreenSizeI=(INDEX)1920;
persistent extern INDEX sam_iScreenSizeJ=(INDEX)1080;

Enjoy the game with a modern resolution standard.
Is this still necessary if I use the binaries ?
Not necessary as you can select widescreen resolutions from ingame settings.