It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Hey Timeslip, unrelated question, but you are involved with creating the Morrowind Graphics Extender right? Do you know if there's plan to include an option to change FOV in some future version? Currently while you can set widescreen 16:9 resolutions (like 1920x1080) with it, but the FOV is still default 75 (4:3).
Crosmando: Hey Timeslip, unrelated question, but you are involved with creating the Morrowind Graphics Extender right? Do you know if there's plan to include an option to change FOV in some future version? Currently while you can set widescreen 16:9 resolutions (like 1920x1080) with it, but the FOV is still default 75 (4:3).
It's been a looooong time since I was involved with MGE. :p

Doesn't the fps optimizer let you change the FOV though? Or was that only an option in the rather buggy 2.0 version?

Edit: And yes, that was very unrelated. If you have random questions like that, you can use a PM. ;)
Post edited May 15, 2012 by timeslip
Just curious, but is there any way to just broadly speed up the combat? Like, make both the player and enemy parties have their bars fill faster?
First of all a big "Thank you", timeslip, for creating this patch! Unfortunately, i have a very annoying problem. With your patch i have the battle ending issue. With the ini tweak ZeroTrig mentioned(ScaleMode=0 and CpuIdle=5), the battle ending works, but the Cpu Idle setting makes my mouse control so laggy, that it´s impossible to control the game.

I´m playing with Win 7 64-bit and Logitech G9x usb mouse and tried several mouse driver settings, but nothing change the lags. I also tried various compatiblity options without any effect.

If there would at least a way to add your UI tweaks to the game, especially the right click on the portraits in combat to queue up a next move, would increase my game experience extremely.

Any ideas what i can do to get your improvements to work?
ZeroTrig: To anybody else who has the end of battle problem, I'm not 100% certain, but I think I found a fix for it. First, make a backup of septerra.ini and open the file in Notepad or any text editor. Then, under the heading "[Options]", you should see the line "English = 1". Underneath that, try adding a line for "ScaleMode = 0" and another line for "CpuIdle = 5" (without the quotations). Then save it, make sure it saved as .ini, then run the game again. Hopefully the bug won't show up this time.


By the way, I'm running Windows 7 64-bit.
Hey, i just tested what you said, but just the cpuidle = 5 part and it worked great.
So, the unofficial patch fixed the videos for me, and your cpuidle part fixed the combat. Thx guys.
(Btw for the video part, videos work fine if i select XP SP3 compatibility option, but the save game isn't there when i use this. And i didn't want to start over :P)
I also have an after battle issue with the unofficial patch. It doesn't freeze or anything, I can continue playing fine, it's just the menus of xp and items that disappear. This only happens when using the unofficial patch and I've tested it on both my GOG and CD version (patched to 104).

However, the CPU Idle = 5 (or any other number) doesn't fix it. I've put it as low as 1 and high as 100. Ctrl-A doesn't seem to do anything at all because it's not hanging, I just can't see the menus. A lot of people have said this fixes their issue, and the only reason that I can think of that mine doesn't seem affected is that I run Windows XP SP3, not Win 7.

Chobit: I also get very bad lag with my mouse at CPU Idle 5 and the only way I fixed it was set it to 1.

Edit: Surprisingly, the Unofficial Patch also takes away ALL menus when I get something. I just picked up some bread from the fridge again and there was no menu stating what I picked up. I just heard the sounds that happen in accompaniment.

NM about the video, turns out it was on compatibility mode.
Post edited June 28, 2012 by Emelisa
Thanks Emelisa for your reply. I forgot to mention that, just as you did, i´ve already tried almost every parameter setting. Unfortunately, the bad lag with my mouse was still existing, even if I set the Cpu Idle to 1. But I´ve overlooked a timing option for the laser in my mouse driver. So finally, I found a more or less acceptable workaround. It still lags a bit from time to time, but at least it´s playable now with all the improvments from the patch.

I´ll keep my fingers crossed that you too find a solution to use the patch without disappearing menus or any other annoying issues :)
It seems someone needs to make a win95 virtual machine for win7 :)
The solutions to old windows games running on newer ones seem to be more of a hit or miss depending on the systems and the moon's position.
That's some damn impressive work! I couldn't even run the GoG version. Although I recently played CDVersion on Win7 x64 just fine. Actually I hope to continue my save game with this version.

Now I have win8 and Septerra complained it's not in registry bla bla. And 1.02 version was the one I had. 1.04 starts fine, with compatibility even plays movies, but than I have a fiickering main menu, which is half the horizontal size and half the vertical size. But it is copied into two horizontally. So basically - upper half of the screen = dual pink main menu flickering epilepsy festival.

Your patch made it work. Just amazing. Although I hope I wont get any other problems, since I CAN NOT use cpuidle at any version since I have the trouble with the mouse lagg as ppl above. I had Razer Deathadder at max dpi, and any value of cpuidle won't work. Let's not worry for now I guess, maybe I won't need it :) I have a quad core and not the fastest one, perchaps that's the reason.

EDIT: Scratch that, with no CPUidle at all it still lags like hell :( Game is completely unplayable. Save works but characters just walks in slomo in place (not actually moving, just showing run animation)
EDIT2: The movies that were transcoded have visually worse quality. In other words, are less sharp.
EDIT3: New game also broken. After canclelling all cutscenes I can't play even with slowmo, game is laggy but responsive. Although Maya won't move, and camera seems to be centered on her Uncle xD

Whether it is windows 8 (unlikely?) or something else, I guess I won't complete my third playthrough. Still your patch is good for those that can run the game itself. Never expected to see any :)

OK, this get's better and better.

Game bearly laggs or does not lagg when I alt tab, make all the black (?) gone (refresh screen) and go back into the game.

Also some smart ass put the game by default on High priority.

Changing the game from High to Normall, even with cpuidle = no lagg and the game works without all the errors mentioned above. (edit 7 or 8 - process priority doesn't matter, it's the black bars)

The thing stops lagging as soon as the black bars disapear (game comes back scaled in center, but on sides you see windows, no black bars. On loading game/area bars are back, but they do not couse lags anymore.

Right clicking portraits in combat couse a temporary game freeze (game unfreezes and you see all bars are loaded, so it may just bee graphics freeze in fact) - edit(I lied) indeed it is. Sounds are still played.

And I can also report invisible after-battle summary and item pickups. But it's either this patch or nothing. I will pass for a while I guess. Maybe someome will tell me how to use windowed mode and it'll fix that lol

Possibly all would work in windowed mode? Just no idea how to turn it on.
Post edited July 22, 2012 by Crusader_bin
Thank you Crusader_bin for this post, alt tabbing does seem to remove all the lag on windows 8 even if the black bars return, spent over an hour trying to get this game to work, which isn't nearly as bad as some other games I've spent 5+ hours getting to work.

I skipped through and ran to the badlands to test out the battle system. I'm running windows 8 pro 64 bit, and with your alt tab trick, I have 0 lag. I also have no issues with getting the combat boxes and item boxes to show up when I receive exp and items. I do not have any of the lines added into my ini file.

To say the least this game is 100% playable on windows 8 with this patch, what some people forget to do is download and install quick time to get the files to convert properly.

I guess I'm not sure why people are not getting the item boxes to appear or why you're getting any lag at all in combat, when I click on portraits or do anything I have virtually 0 lag. Maybe give it another try? I'm not sure, the only thing I do have is compatibility mode set for windows Vista (service pack 2), not sure why but any of the old games i play that require dosbox, require me to have compatibility mode set for Vista in order to work properly. I've tried all the other ones, but it seems that Vista is the only mode that works properly.

To play Septerra Core in windowed mode btw just add the line -windowed with a space after the Target line in properties. This only works if you have the unofficial patch, otherwise you'll have to set color depth to 16 bit as well, under compatibility mode.
Tomizor, it is funny that I happened to try with the game again and it so happens you posted that yesterday :)
I installed quicktime alternative this time (Quick Time itself is a malware/bloatware lol), Installed the game, the fix, alt tabbed and... it just works.

Might be that I had problems before because Win8 was beta at the time. Now obviously it is not. Or maybe the new interface when ctrl+alt+tab refreshes differently (black bars just disapear now easily). Or maybe it's the different gpu drivers, seeing as I am not the only one who had problem with invisible inventory items.

The only thing I regret is that I don't have my save game anymore... Still it is awesome to have the game working again :) Although right clicking portraits still do nothing (unless you call brief game freeze a "thing").

I probably wouldn't have tried installing the game again if not for your post, so thanks!

Edit: Oh, and no compatibility or anything. It seems odd that Vista compatibility would be usefull at all for anything, since Vista - win7 - Win8 are all built pretty much the same :) It's just another wonder, where things that should do a lot do nothing, and those that should do nothing do a lot. Computers. And magic.
Post edited January 26, 2013 by Crusader_bin
Hi everyone,

i'am new at GOG and thanks to this post i finallly could install and run Septerra Core.
I just have to install Quick Time for Video conversion. ... Do i really need Quick Time?

For this lagging issue on Windows 8 i might have one more solution.
For me it works after patching Septerra Core with unofficial Patch and start it with compatibility Options you see below.

- Win XP SP3
- 16-Bit Color
- Screen Resolution 640 x 480
- Admin (optional)

With 640 x 480 Resolution the game goes full Screen but is lagging anyway. Together with 16-Bit Color the lag is gone. ... on my maschine.

Have a nice day!
This is an impressive work.

Please, if possible, can mods make this a sticky?
Yes, this patch is very helpful. I got the battle ending issue, but I fixed it with the cpu-line in the .ini.
It makes the game much more comfortable to play.

In some cases the right click queue during the battles gets mixed up. The bar keeps filling up, although there is a blue dot, but it's not such a big deal.
Running on Windows 8 x64.

Wanted to add my thanks for this patch. I installed Quicktime Alternative, ran the patch, saw the video files converted, and added the CPUIdle = 5 and ScaleMode = 0 parameters. When I launched the game it actually worked - I had video, no purple graphics, and a playable game.

I've tried the -windowed parameter for the shortcut. I don't know if I'll keep that or not. It's a little small, but workable. It works in both windowed and non-windowed modes.

I agree that the videos aren't as "crisp" as they could be otherwise, but I can live with that considering that we're transcoding the videos from QT to AVI format. They're watchable and show what's going on. That's a small price to pay for a playable game. :)

I haven't tried without compatibility mode yet, but it's definitely been more playable than before. Thank you for your help on this.