It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I played this years (and years) ago. Still have the original package. Wanted to have that GOG magic and enjoy it on a more modern machine. I purchased and installed from GOG jst an hour ago. And there is where the GOG magic failed me.

The install was fine, but what I am seeing is:

- First 4 videos are fine (company spots and background story)
- The first in-game video (where there is a discussion in a "throne room") is just a black screen and no audio (although the game banner appears at bottom). Eventually the next video sequence begins (Chosen ships and May, etal, are on the desert) and plays fine(ish).
- When you get control in the game the audio/video sync is extremely poor
- character animations begin but never finish (in first scene there is some walking but it's all in-place)
- mouse lags and jumps (not moving smoothly)
- controlling Maya is impossible due to mouse issues.
- interacting with any menu is impossible due to mouse issues.

I am playing on Win10 with game in XP SP3 compatibility mode.Running on a 2012 laptop. I'm on the road atm, but when I get home in a couple weeks hopefully I can find the answers to make this run well. Of course, by then, I won't be able to get a refund or credit.
You can check the threads here for various fixes. I've found two different methods that worked for me.

Method 1

Method 2
After default installation, modify septerra.ini in your installation folder and set the values to the values below and give it a try.

CPUIdle = 0
ScaleMode = 3

(CPUIdle = 0 removes mouse lag, scalemode removes screen flickering caused by fullscreen. Explanations of values are in UOPatchReadme.txt)

The first method has the best visuals and least problems for me, but it does not have the "right click in battle to enqueue character stamina bar" mechanic which comes with the default unofficial patch (installed along with the game).

The second method has that mechanic, but has a little smaller gameplay screen and occasional mouse click issues in the game (nothing too serious).
Post edited March 18, 2023 by Excolion
Thanks for the suggestions. Tried the second method first, same issues prevail. I'll work on the first method now, although it seems more focused on the cutscene "movies".

Until I finish my travelling (and can really dig into a complete solution for me), I'll rename (effectively removing) ddraw.dll and QuickTime.qts). So the AVIs won't play as part of the game, I do get a smooth mouse and everything else works fine. I can live with that for now. (I didn't mention initially as I didn't know it mattered, my laptop is running with an NVIDIA Quadro 1000M.)

I am a little surprised GOG is offering Septerra Core as a free addition in a bundle with a new game. I hope others don't have issues.
Post edited March 20, 2023 by chricton
I tried all methods but I don't get it running under Win 10.
It was a nice game, I bought it from Topware and loved to play it.
I would love to play again, but alas no way to do it.