It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Any way to change the aspect ratio and remove fullscreen? Doesn't seem to come with a graphics configuration app. :P
IF this runs in ScummVM, then I guess you need to locate the game's INI file inside its main folder and edit it to change the fullscreen setting to false, then it'll run in a window.
After some messing about I've come up with this.

To get the game to start up windowed:
- Go to the main game folder
- ex. C:\GOG Games\Sam and Max Hit the Road
- open samnmax.ini change fullscreen=true to fullscreen=false and save

Useful controls:
- F5 = ScummVM main menu
- Ctrl+Z = Exit game
- Alt+Enter = Switch fullscreen/windowed
- Spacebar = pause

For some reason fullscreen won't display proper aspect ratio it stretches the image. Windowed it displays correctly though. I guess I've never used ScummVM before. :P
avatar
YnK: IF this runs in ScummVM, then I guess you need to locate the game's INI file inside its main folder and edit it to change the fullscreen setting to false, then it'll run in a window.
Thanks. + rep
Post edited October 28, 2014 by Outerdementor
According to the ScummVM-help CTRL-ALT-A toggles aspect ratio correction.
avatar
Laserschwert: According to the ScummVM-help CTRL-ALT-A toggles aspect ratio correction.
Tried it. Just makes it look worse though. Thanks for trying.
Post edited October 28, 2014 by Outerdementor
avatar
Outerdementor: Any way to change the aspect ratio and remove fullscreen? Doesn't seem to come with a graphics configuration app. :P
Check your graphics card control center and select "Maintain Aspect Ratio" and "GPU scaling" or similar if your display does not support correctly displaying the resolution.
avatar
sponkaps: Check your graphics card control center and select "Maintain Aspect Ratio" and "GPU scaling" or similar if your display does not support correctly displaying the resolution.
This worked. Thanks for the help. :D
Post edited October 28, 2014 by Outerdementor
avatar
Outerdementor: Any way to change the aspect ratio and remove fullscreen? Doesn't seem to come with a graphics configuration app. :P
avatar
sponkaps: Check your graphics card control center and select "Maintain Aspect Ratio" and "GPU scaling" or similar if your display does not support correctly displaying the resolution.
Ah, will try this. Thanks!
I've changed my ScummVM settings on the menu to full screen. However, this zoomed in way too much on my screen, and I couldn't even use my mouse. I found out I could press ALT-Enter to change it back to windowed mode, but while it is in a window now, it is still stuck in the top-left corner of my screen and I can't even click on parts of the left side of the window. Please help! The attached pictures below show how much I can see on the window. As you can see on the second one, I can't even turn off the full screen option. Can you please tell me what I should do? Also I've tried deleting and re-downloading the program, but that did absolutely nothing.
Attachments:
Post edited August 22, 2017 by Warri0rlink
You don't have to hunt for and then edit the .ini file with ScummVM games. Whilst in a game press F5 to get to the options and then click on "Return to Launcher" this will exit the game (but not ScummVM) leaving you free to configure the game.

"Options" button leads to global ScummVM settings and is pretty irrelevant here since this is a standalone version of ScummVM. All of the options in here are under the [scummvm] section of the .ini file.

"Edit Game" button lets you configure the selected game, in this case Sam & Max. All of the options in here will fall under the [samnmax] section of the .ini file. Also not everything shows up in the .ini file until you change something so it's best to use the client to configure stuff just in case the option you were expecting to see in the .ini file is in the client but not the file.