It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Hello,

I can't seem to get the frame rate above 30 fps. I have the steam version, which has performance issues as well, but it almost never hits 30 fps or below.

I read about a patch that unlocked the frame rate that sounded like the game was originally locked to 30 fps. Is that a patch I'm missing?

I'm confused because I didn't see any threads or posts about it here, so I wasn't sure if it was a general problem or one specific to me
No posts in this topic were marked as the solution yet. If you can help, add your reply
It's an intentional fix the GOG team have added to this release to fix cutscene issues if I recall correctly.

The cap is forced via an older version of Nvidia Inspector located at C:\ProgramData\GOG.com\Galaxy\support\1430740458\1430740458\add\NVI\
Really...aww...

Maybe it'll be tolerable with a gamepad. It really sucks for kb/m.

Oh well...$4.99 for Saint's Row 3 is a steal. BRING ON SR4!
Yeap the game is horrible at 30fps. Back to the steam version as I am sure that runs at 60fps with a simple fix to stop the game running to fast.
avatar
nvidiac: Really...aww...

Maybe it'll be tolerable with a gamepad. It really sucks for kb/m.
I switch between keyboard+mouse for combat and gamepad for driving.

That said, the wired xbox 360 controller for windows is $28 right now.
avatar
voorhees1979: Yeap the game is horrible at 30fps. Back to the steam version as I am sure that runs at 60fps with a simple fix to stop the game running to fast.
? The game's fine at 30fps... Quite playable.
so i got it on steam and i guess this gog.com version isnt useful then?
You can turn off the FPS limitation on the nvidia inspector. GOG should make this "fix" optional.
avatar
voorhees1979: Yeap the game is horrible at 30fps. Back to the steam version as I am sure that runs at 60fps with a simple fix to stop the game running to fast.
avatar
shadowknight2814: ? The game's fine at 30fps... Quite playable.
Not after you have played it at a higher framerate, why would I play at 30fps when I can play at 60fps on the steam version?
avatar
MrBoat: You can turn off the FPS limitation on the nvidia inspector. GOG should make this "fix" optional.
How do you turn it off? I dont see the setting in the Inspector?
Post edited May 17, 2015 by Witcher_1979
Here's a good way to learn how Inspector works:
https://www.youtube.com/watch?v=H09MdIpR-uA

Simply, you go to:
C:\ProgramData\GOG.com\Galaxy\support\1430740458\1430740458\add\NVI

Click on the button that's next to the Driver Version, put Saints Row 2 on the search filter, go to the bottom and you'll find "Frame Rate Limiter" highlighted. Click on the right button to change it to it's default setting or just select "PS_FRAMERATE_LIMITER_DISABLED".

Once again... A very bad move, GOG. Change your installation script as soon as possible. If people run into problems give this "fix" for them separately.
avatar
MrBoat: Here's a good way to learn how Inspector works:
https://www.youtube.com/watch?v=H09MdIpR-uA

Simply, you go to:
C:\ProgramData\GOG.com\Galaxy\support\1430740458\1430740458\add\NVI

Click on the button that's next to the Driver Version, put Saints Row 2 on the search filter, go to the bottom and you'll find "Frame Rate Limiter" highlighted. Click on the right button to change it to it's default setting or just select "PS_FRAMERATE_LIMITER_DISABLED".

Once again... A very bad move, GOG. Change your installation script as soon as possible. If people run into problems give this "fix" for them separately.
Thanks very much :) I will try this in a few mins.
avatar
MrBoat: Here's a good way to learn how Inspector works:
https://www.youtube.com/watch?v=H09MdIpR-uA

Simply, you go to:
C:\ProgramData\GOG.com\Galaxy\support\1430740458\1430740458\add\NVI

Click on the button that's next to the Driver Version, put Saints Row 2 on the search filter, go to the bottom and you'll find "Frame Rate Limiter" highlighted. Click on the right button to change it to it's default setting or just select "PS_FRAMERATE_LIMITER_DISABLED".

Once again... A very bad move, GOG. Change your installation script as soon as possible. If people run into problems give this "fix" for them separately.
maybe like the witcher 3 downgrade ;D
lol!

I was thinking the same yesterday, Caine123. It's important to notice that this "fix" has no reason to exist on Win 8.1.
Please, if you're having problems to make it work smoothly visit my yesterday post:
http://www.gog.com/forum/saints_row_series/low_fps_saints_row_2/post4

You welcome Witcher_1979 :)
Post edited May 17, 2015 by MrBoat
avatar
Caine123: maybe like the witcher 3 downgrade ;D
You have two choices, enjoy the full experience of the story without having your PC having frame rate issues OR....enjoy the sightseeing of graphics without giving a single care to the lore or the gameplay and then whine like a little child because the game is "not optimized".

I'd pretty much take the 1st one and if the game has frame rate issues with my video options, i just lower it.
avatar
shadowknight2814: ? The game's fine at 30fps... Quite playable.
avatar
Witcher_1979: Not after you have played it at a higher framerate, why would I play at 30fps when I can play at 60fps on the steam version?
I've beaten it at 30fps on the PS3... It's fine. Really. I've played games with noticeable frame-rate issues, and no matter how it is on SR2, it's not noticeable to me.