It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Alright... so... I've got the Alienware M11x R1 Gaming Laptop from 2009.

Specs:
Win7 x64
Core 2 Duo SU7300 (1,73Ghz)
[HYBRID] Dedicated GeForce GT 335M 1GB / Integrated Intel HD
8 GB RAM & 256 GB SSD

It runs Skyrim, Fallout 3, Dead Space, Crysis 1, Borderlands 1, Burnout Paradise and many other Games just fine with FPS > 30. Crysis runs fine on 2nd highest Settings [so, not "Ultra" but just below that]. So, all I have to do sometimes, in some Areas / Instances, is lower the Settings a bit.

Saint's Row the Third runs on 60 FPS in all indoor Areas, outdoors it's about 23 and lower on DX11.
On DX9, it doesn't even start, though. Huh.

Now, Saints Row 2, it really doesn't matter at all what Settings I select.
Everything maxed out, 5-8 FPS.
Everything on minimum, 5-8 FPS.
Character Creation Screen, 5-8 FPS.
Walking around, 5-8 FPS.
Main Menu, 5-8 FPS.

What's going on here...?
The Consistency of 5-8 FPS makes me think it's using my Integrated Intel HD, instead of my dedicated GeForce. I've found LOTS of Forum Posts where People with the M11x R2 have similar Issues, though these Guys are using Optimus, a Program that allocates starting Programs to specific Gs automatically. In my Case, I'm switching manually, to either completely use dedicated or integrated Graphics. If I'm in dedicated Mode, everything uses GeForce. Yet somehow, I get the Impression Saints Row 2 doesn't play nice and especially utilizes the Intel Chipset instead.

Also, what is this weird "Inspector" that messes with my nVidia Settings?

What can I do? Just ask for Refund? This Problem has been around since Release, as it seems - and every Solution adressing Optimus not allocating Saints Row to the GeForce is useless, since I'm the one who's switching my whole System into dedicated GeForce Mode. Yet, Saints Row seems to just ignore that. This never happened before.
Post edited October 19, 2015 by BlackSun
No posts in this topic were marked as the solution yet. If you can help, add your reply