It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

i have the latest phys x and legacy, its on admin
when i launch i get a black screen then it closes to my desktop
No posts in this topic were marked as the solution yet. If you can help, add your reply
same here. sorry just a "me too" not a real soloutoin
not even a black screen just won't launch at all
have tried everything
reinstall physx legacy
downloaded physx legacy from nvidia website and manual reinstall(after clean uninstall)
reinstall risen
change resolutron and refresh rate to 1280x1024 and 60hz and even down as low as 640x480 no go!
ran as admin
since you are not getting a reply here I am going to post this issue and see If I get luckier.
this game worked fine until today.
using Geforce 1080 GTX with latest drivers
Windows 10 Pro updated to today's "Cumulative" update patch(KB4505903-July 26 2019)
you might try running cmd(as administrator) and sfc /scannow but I doubt it will work It might if your file structrure is damaged. also if you had Ransomware protection(windows defender) on during installing risen and if you used Galaxy to install it try uninstalling Risen(using CCleaner afterwards) and reinstall make sure ransomware protection is turned off.
I got it to work by doing the folowing(and I don't konw what exactly it was speciically but try this)
use Revo to uninstall Risen
uninstall physx legacy and reinstall(using in game installer or download and do it manually)
ccleaner both registry and standard ops
do this twice(incalse CC missed something critical)
run a standard scandisk(just right click drive and do the normal one, no need for chkdsk)
make certain "controlled folder access"(ransomeware protection) is turned off
reinstall risen and physix legacy
and reboot
seemed to work for me